Jump to content

[RESOLVED] Login Issues



20 replies to this topic

#1 ScrewCityChris

    Member

  • Legendary Founder
  • 700 posts
  • LocationMadison, WI

Posted 28 February 2012 - 09:58 AM

OS: Android OS 2.3.6
Phone: Motorola Razr

Problem:

When I try to log onto the forums from my phone I get the log in window box as an overlay over the regular forums in the center of the screen.

If I tap/press on the log in name box the screen zooms in, and the log in box disappears. It is replaced with a large black box that is semi-transparent and I can see the forums faintly in the background. Once in a while my virtual keyboard actually shows up (typically it doesn't) however once a digit or 2 are entered to try to log in, it disappears and I am once again left with the large black semi-transparent box overlaid on the forums.

All other aspects of the site seem to work just fine, just having the log in problems. Have not had these problems with any other forums or websites to my knowledge.

#2 Volume

    Member

  • Legendary Founder
  • 1,042 posts

Posted 12 March 2012 - 09:39 AM

What browser are you using? I can do it fine on my Dolphin HD, but Firefox mobile seems to not work. Haven't tried Skyfire or anything else.

To be fair, the "overlay" aspect of the login box (which is normally incredibly sexy), does "dim" the login box when I go to log in, but it works okay. Also if I mess up and it goes to the "invalid username/password combination" screen, that's much easier to log in on.

edit: Samsung Fascinate (Galaxy S)

Edited by Volume, 12 March 2012 - 09:39 AM.


#3 Kusiami

    Member

  • Members
  • PipPip
  • 25 posts

Posted 25 March 2012 - 11:16 PM

It's inconvenient to have to log in every time we visit the site. Cookies are not the devil, so please give us one so we can stay logged in for as long as we like!

#4 Spooky

    Member

  • Veteran Founder
  • 338 posts
  • LocationAustria

Posted 26 March 2012 - 12:20 AM

I'd also settle for the ability to let the browser actually save and fill in the password.

#5 Spooky

    Member

  • Veteran Founder
  • 338 posts
  • LocationAustria

Posted 26 March 2012 - 12:27 AM

View PostKyle Polulak, on 23 February 2012 - 03:10 AM, said:

The login system has been tweaked to eliminate some odd issues with the need to login twice, and to return to the previous page when logging in. These changes include,

  • Forcing the use of our global domain name, mwomercs.com. It will automatically redirect you to this domain if you use any aliases or sub-domains.
  • Check the HTTP_REFERRER header of your browser to redirect you to the page you were on when logging in.

These tweaks will roll out over the next few days to our users, and should you encounter any issues please clear all your cookies for our domain .mwomercs.com and your browser cache then restart your browser.

Did this actually make it in yet? I am still redirected to the home page of mwomercs.com, instead of the site I was on after logging in.

#6 Spooky

    Member

  • Veteran Founder
  • 338 posts
  • LocationAustria

Posted 26 March 2012 - 12:40 AM

This is how it looks in the regular Android Browser on a Nexus S with ICS 4.0.3:

Posted Image

It looks the same in the Chrome Beta. Logging in this way is very inconvenient, because the overlay causes a severe performance drop in the regular Android Browser and typing in your login details is basically impossible. For some reason all text always gets deleted, when you want to switch to the next input field. Google Chrome also spasmed the first time I tried to put in my login details.

However, a better solution is to go to mwomercs.com/login instead. There no such issues will arise and I think even password saving works.

Edited by Spooky, 26 March 2012 - 12:40 AM.


#7 DHarhanGW

    Member

  • Members
  • PipPip
  • 24 posts
  • LocationOntario

Posted 26 March 2012 - 03:42 AM

Seriously? Okay, I can understand that that'd be a little more convenient, but do you really want the devs wasting time on things that'd be convenient instead of the game itself? lol

#8 Spooky

    Member

  • Veteran Founder
  • 338 posts
  • LocationAustria

Posted 26 March 2012 - 03:57 AM

View PostDHarhanGW, on 26 March 2012 - 03:42 AM, said:

Seriously? Okay, I can understand that that'd be a little more convenient, but do you really want the devs wasting time on things that'd be convenient instead of the game itself? lol

Uhm, the devs working on the core game are probably not the same devs working on the website and other online features :). Even considering that, your argument is not really valid, because if you always say that you don't want to "waste time" on "convenience issues", then imagine how any game, application or website interface will turn out to be...



Btw., as a side note, I completely forgot that browser auto fill in works on mwomercs.com/login. But naturally it would still be nice, if auto fill in would work on the login overlay as well and if the login process redirects you to the page you were previously on, instead of going to the home page.

Edited by Spooky, 26 March 2012 - 03:59 AM.


#9 Kyle Polulak

    Web Developer

  • Administrators
  • The Devoted
  • The Devoted
  • 554 posts
  • LocationVancouver, BC

Posted 26 March 2012 - 04:50 PM

Login and Signup pages are going under a drastic overhaul. Please stay tuned.

#10 Victor Morson

    Member

  • Elite Founder
  • 6,269 posts
  • LocationAnder's Moon

Posted 29 March 2012 - 10:32 PM

Recently, I was talking to friends on the forums and realized this wasn't an issue specific to me - why I had never brought it up before. Basically, the "Keep Me Logged In?" check box on the MWO forums doesn't work. Regardless if it's checked or not, it logs you out typically in 15-20 minutes, or the minute you steer away from the page.

As I'm trying to check my PMs for messages throughout the day, it's a little annoying having to login repeatedly; I have a feeling this is a bug with the forums, however; it doesn't seem intentional and isn't how this button works on any other forum.

I'm using Firefox and so are my friends, but I've also encountered this with Internet Explorer on a remote computer. Is anyone else getting this? Do they stay logged in when the box is checked?

EDIT: Apologies for putting this in the wrong forum to start. I missed a website support sub-forum somehow on my glancing where to post; thanks for moving it!

Edited by Victor Morson, 30 March 2012 - 05:10 AM.


#11 TopDawg

    Member

  • Elite Founder
  • 256 posts

Posted 29 March 2012 - 10:38 PM

I primarily use Chrome and experience the same issue.

Edited by TopDawg, 29 March 2012 - 10:38 PM.


#12 Wyzak

    Member

  • Legendary Founder
  • The Resolute
  • The Resolute
  • 251 posts
  • LocationHartford, Vermont

Posted 29 March 2012 - 10:44 PM

I think everyone has this. I ran into it on Firefox as well and I'm sure IE would manifest the same behavior.

#13 Logan Winters

    Member

  • Members
  • PipPip
  • 45 posts
  • LocationColorado

Posted 29 March 2012 - 10:45 PM

I'm on interned explorer and have a similar issue.

Not really even an issue. More of a minor inconvienience.

Like a small hover tank, or some infantry.

#14 Thorn Hallis

    Member

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 4,663 posts
  • LocationUnited States of Paranoia

Posted 29 March 2012 - 10:55 PM

View PostWyzak, on 29 March 2012 - 10:44 PM, said:

I think everyone has this. I ran into it on Firefox as well and I'm sure IE would manifest the same behavior.


Nope. Had that neither with IE nor Firefox, on different machines.

#15 SmoesHammer

    Member

  • Elite Founder
  • 204 posts
  • LocationDublin

Posted 30 March 2012 - 12:57 AM

Yeah, i get it on Chrome, Mac and PC.

#16 Hador

    Member

  • Legendary Founder
  • The Ironclad
  • The Ironclad
  • 544 posts

Posted 30 March 2012 - 01:28 AM

Quote

What the system won't do:
  • Log you in automatically.
  • Keep you logged in if you close all tabs/windows from mwomercs.com.
  • Keep you logged in if you close your browser.


The moment you close your MWO page/browser, you're out. Working as intended I guess.

#17 SmoesHammer

    Member

  • Elite Founder
  • 204 posts
  • LocationDublin

Posted 30 March 2012 - 02:21 AM

On most other forums this means i can close it, restart the browser etc. and then when i open it again i will be automatically be logged in, what is the problem with that?

#18 Hador

    Member

  • Legendary Founder
  • The Ironclad
  • The Ironclad
  • 544 posts

Posted 30 March 2012 - 03:46 AM

PGI has stated what the "keep me logged in" does and what it does not.

http://mwomercs.com/...p-me-logged-in/

I prefer it the other way as well but it's their call.

#19 Victor Morson

    Member

  • Elite Founder
  • 6,269 posts
  • LocationAnder's Moon

Posted 30 March 2012 - 05:14 AM

View PostHador, on 30 March 2012 - 03:46 AM, said:

PGI has stated what the "keep me logged in" does and what it does not.

http://mwomercs.com/...p-me-logged-in/

I prefer it the other way as well but it's their call.


This definitely explains it.

However, I think sometimes merely closing a tab is enough to actually kick me out; I've gotten bumped off quite a bit without actually closing the entire browser. I often have a bunch of tabs to the forums up, mostly because the Aces have been recruiting and I want to monitor the messages/thread to get back to people.

It's unfortunate it's not the other way; these threads aren't private, which is the only time I've ever encountered this kind of setup before. All the other public forums I've ever visited keep me logged in indefinitely, even ones with some extreme security rules (I think it's a 20 character password minimum now?) like SomethingAwful.

#20 ice trey

    Member

  • Legendary Founder
  • Phoenix Overlord
  • Phoenix Overlord
  • 701 posts

Posted 01 April 2012 - 11:40 AM

Hey guys.

I know that there are security issues with using the "Remain Logged in" feature for the forums. That has already been addressed.

However, one thing that rubs me the wrong way with the login is that it bounces you back to the central page, rather than letting you stay on the topic that you've been reading, making you hunt for it all over again.

Can this please be addressed, so that logging in while reading a topic will let you stay in that topic once the login is complete?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users