Jump to content

[Bug] Can't Use More Than 3 Mouse Buttons


32 replies to this topic

#21 Famine 4H

    Member

  • Legendary Founder
  • Stone Cold
  • Stone Cold
  • 17 posts
  • LocationWashington, USA

Posted 01 March 2013 - 10:55 PM

The mouse is not the problem. On my wife's computer I can assign ALL of the buttons to various functions. I take the SAME mouse and plug it into my Alienware and *poof* no support in MWO for buttons 4, 5, etcs.... So I don't think it's a driver issue.
(I don't have a logitech so I don't have SetPoint)

#22 CmdrPoopyPants

    Member

  • Members
  • PipPipPipPipPipPip
  • 376 posts
  • LocationOshkosh, WI

Posted 01 March 2013 - 11:54 PM

One of the threads I found here helped me.. in the mouse control software, you have to set the buttons to 'generic button', then they can be assigned. I don't know if you can set a profile for the application (especially since it launches a new window/process to run the game), but after setting the buttons to generic, I can use 1, 2, 3, 4, and wheel down all just fine. --- Logitech M510 wireless..

#23 Badconduct

    Dezgra

  • Banned
  • PipPipPipPipPipPip
  • 364 posts

Posted 02 March 2013 - 06:42 AM

View PostElddar, on 09 November 2012 - 10:43 AM, said:

Just go into Logitech's Setpoint app and assign keystrokes to the buttons.


Same issue with a G9 and this solved it.

#24 Draxa

    Member

  • Legendary Founder
  • 37 posts

Posted 02 March 2013 - 01:46 PM

These problems are why I like mice with on board memory. Just program the buttons the way you like, save to on board memory, and never worry again. Logitech G700, best mouse I have ever used.

#25 Darknight99

    Member

  • Members
  • PipPipPipPipPip
  • 115 posts

Posted 02 March 2013 - 01:54 PM

I know that when I make any weapon group changes it doesnt take effect the first round. I have to wait till that match is over then I can use the buttons I set. (logitech g700)

#26 Koniving

    Welcoming Committee

  • Legendary Founder
  • The Ironclad
  • The Ironclad
  • 12,413 posts

Posted 02 March 2013 - 02:02 PM

Mine accepts all seven of my buttons.

It accepts mouse buttons 1 through 5. The remaining two take the place of two keys on my keyboard.

#27 CmdrPoopyPants

    Member

  • Members
  • PipPipPipPipPipPip
  • 376 posts
  • LocationOshkosh, WI

Posted 02 March 2013 - 03:06 PM

View PostDarknight99, on 02 March 2013 - 01:54 PM, said:

I know that when I make any weapon group changes it doesnt take effect the first round. I have to wait till that match is over then I can use the buttons I set. (logitech g700)



What you might be seeing here is the broken grouping code. If you change weapon groups, it kind of hoses the existing groups. What I do is, set everything to 3 (or 6 or 5 or whatever you're not going to use).. Then I deselect everything from the main groups.. then I deslect everything from the junk group.. then I set the groups I want (and if I set something and then remove a weapon, I deselect the entire group, put the weapon in the right group, then reselect the entire group I meant to pick).

I used to get weapons firing out of group if I didn't do that.. and I got tired of trying to figure out what the exact bug is.. so I found that by dumping everything and resetting everything, it cleared the bug and everything worked as expected.

#28 Warskull

    Member

  • Members
  • PipPipPipPipPip
  • 157 posts

Posted 02 March 2013 - 07:56 PM

The mapping screen has 3 columns. Make sure you only map mouse buttons in the second column. When I map mouse buttons in the first column they just don't work, when I map them in the second column they do.

#29 Lhoxy

    Rookie

  • Members
  • 2 posts

Posted 29 March 2013 - 08:20 AM

Hi there,

Im new to this game, managed some traininggrounds yet and found out that I have a similar problem with my Razer Diamondback 7 button mouse.
I can only use 2 buttons of my 7 :P I alrdy tried to assign the not working buttons to keyboard keys (example: key #3 to middle button or #4 to a side key for using more than just 2 weapon groups, but it aint work.
I could live with 3 working buttons...but only 2 is far to less.
(I dont have any probs with this in other games. All buttons working fine, for example in BF3)

Any news or help on this issue ?

Thx

#30 CmdrPoopyPants

    Member

  • Members
  • PipPipPipPipPipPip
  • 376 posts
  • LocationOshkosh, WI

Posted 29 March 2013 - 09:28 AM

View PostLhoxy, on 29 March 2013 - 08:20 AM, said:

Hi there,

Im new to this game, managed some traininggrounds yet and found out that I have a similar problem with my Razer Diamondback 7 button mouse.
I can only use 2 buttons of my 7 ;) I alrdy tried to assign the not working buttons to keyboard keys (example: key #3 to middle button or #4 to a side key for using more than just 2 weapon groups, but it aint work.
I could live with 3 working buttons...but only 2 is far to less.
(I dont have any probs with this in other games. All buttons working fine, for example in BF3)

Any news or help on this issue ?

Thx



As noted earlier in this thread, try setting the keys to "generic button" so it reports as a "mouse button X" to the OS. That got several of my other buttons working on my mouse. Having them mapped to key strokes wasn't letting me assign them for whatever reason.

#31 Lhoxy

    Rookie

  • Members
  • 2 posts

Posted 04 April 2013 - 04:17 AM

Ya, I checked that generic thingy but I guess it has something to do with the logitech-software. Im using a Razer.
Anyway, as far as I know its stuff for binding keyboard keys to mouse buttons. I've allready done this with the Razer software, called "advanced" buttons.
But still no reply from button 3,4 and 5.
So I have to go on with only 2 working buttons.

Maybe its cause the razer-software is a bit older and doesnt been supported anymore. Version 6.02.

Greets and thx.

#32 Syllogy

    Member

  • Legendary Founder
  • 2,696 posts
  • LocationStrana Mechty

Posted 04 April 2013 - 04:50 AM

I use a Razer Naga, no problems with setting keystrokes in the Razer Drivers. Just sayin'. :D

View PostLhoxy, on 04 April 2013 - 04:17 AM, said:

Ya, I checked that generic thingy but I guess it has something to do with the logitech-software. Im using a Razer.
Anyway, as far as I know its stuff for binding keyboard keys to mouse buttons. I've allready done this with the Razer software, called "advanced" buttons.
But still no reply from button 3,4 and 5.
So I have to go on with only 2 working buttons.

Maybe its cause the razer-software is a bit older and doesnt been supported anymore. Version 6.02.

Greets and thx.


Download the latest version of Razer Synapse?

#33 Hedonism Robot

    Member

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • LocationSpace Pirate

Posted 14 April 2013 - 10:52 AM

I am using a logitech g500 mouse and running into a couple of problems. I have found that if I set clicks to genaric buttons in setpoint I can use more than 2 buttons, but I am confused why the mouse fails to respond to bindings of keystrokes or even clicking other commands.

I am trying to make the mouse fire 4 weapon groups in sequence for AC2 fun times. I want to hit 1-2-3-4 with a short 30 ms space inbetween each when i hold down a button on the mouse (just a small tweak to chain fire timing). In windows without the game running the macro rus without a hitch and works perfectly when testing in notepad. However when I run the game it sometimes doesn't even respond to the click for up to 5 seconds, then all the timing is terribly off.

I thought the g500 mouse ran the macro profiles onboard but maybe I was mistaken. Is there somekind of timing and sync issue going on in the windows driver and the cry engine?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users