Jump to content

Can't Buy Mc's

Contact Support

39 replies to this topic

#1 RedRover55

    Member

  • PipPip
  • 29 posts

Posted 30 July 2013 - 02:10 PM

I am attempting to buy 6,500 MC's this afternoon after the patch and the page appears to be dead. I am properly logged in to my account. The country select and quantity select seems to be working, but the "Buy Now" button seems to be completely non-functional. Tried it several times with no luck. Closed and opened the browser and still no luck.

My browser shows a message "javascript(0):" when I push the button, but I don't know what that means.

I have previously bought MC's with this account.

Later:
I continued messing with it and eventually it let me buy the MC's. I have no idea why it failed or succeeded.

#2 ShadowFacade

    Rookie

  • FP Veteran - Beta 1
  • FP Veteran - Beta 1
  • 7 posts

Posted 03 August 2013 - 06:15 PM

I'm currently having this same problem, in which the script reads Void 0 which returns an undefined result in the page scripting. Does this issue self-resolve after a while?

#3 Berkov

    Rookie

  • Bad Company
  • 1 posts

Posted 04 August 2013 - 12:23 AM

View PostShadowFacade, on 03 August 2013 - 06:15 PM, said:

I'm currently having this same problem, in which the script reads Void 0 which returns an undefined result in the page scripting. Does this issue self-resolve after a while?

Same.

#4 CorporalTermit

    Rookie

  • 1 posts

Posted 04 August 2013 - 02:05 AM

Got the same. Tried with different brousers and PCs. Same situation.

#5 The Good Ed

    Rookie

  • 3 posts

Posted 04 August 2013 - 10:42 AM

Same issue here... My location seems to default to UAE. Try to click "buy", and it's a dead page.

#6 ShadowFacade

    Rookie

  • FP Veteran - Beta 1
  • FP Veteran - Beta 1
  • 7 posts

Posted 04 August 2013 - 11:03 AM

It's still currently not working. The problem is with the page itself, within the javascript coding. Pleas fix this A.S.A.P. Thanks.

#7 Noyce

    Rookie

  • The Money Maker
  • The Money Maker
  • 4 posts

Posted 04 August 2013 - 12:35 PM

i am having the same exact problem,

[color=#959595] "javascript(0):" [/color]
[color="#959595"]i tried to re-install java, reboot comp , and tried different browsers, and clearing my catch/history, have been trying for 12 hours now. [/color]

#8 Beik Ross Norst

    Member

  • PipPipPip
  • Giant Helper
  • 61 posts
  • LocationEerie, PA

Posted 04 August 2013 - 03:40 PM

me too, javascript void. between this and my Sarah's Jenner issue my confidence in MWO is low

#9 Kragg Relluf

    Member

  • PipPip
  • Overlord
  • 35 posts

Posted 04 August 2013 - 03:51 PM

Me too! Please fix - I want to give you money!

It's funny when the thing that takes our money breaks. I bet it's chaos at PGI right now. I feel bad for the developers. The finance people broke the glass that says "Break in case of lost revenue", and handed out the whips within to the HR people, who shared them with the marketing and business development team. They're all standing over the developers now whipping them - basically the business people whipping the engineering people. This only happens when money is being lost. The rest of the time they just whip they just give them a hard time via email and meetings.

#10 Crazyjose85

    Rookie

  • Bad Company
  • 4 posts

Posted 04 August 2013 - 08:38 PM

gonna revive this thread, im having exactly what the original post is having.

#11 Halfmuh

    Rookie

  • FP Veteran - Beta 1
  • 5 posts

Posted 05 August 2013 - 04:53 AM

Upping
still not resoleved
using firefox. tryed crome aswell

#12 Kragg Relluf

    Member

  • PipPip
  • Overlord
  • 35 posts

Posted 05 August 2013 - 03:53 PM

Just tried again - still broke. Please let me give you money!

#13 Noyce

    Rookie

  • The Money Maker
  • The Money Maker
  • 4 posts

Posted 05 August 2013 - 10:24 PM

still having same exact problem : the 'buy now' button dose nothing but let me click on it, nothing happens, then i wait re-log, try again still nothing, change browser, nothing.

#14 Dankinoid

    Rookie

  • 4 posts
  • Google+: Link
  • Facebook: Link
  • LocationMoscow, Russia

Posted 06 August 2013 - 12:44 AM

It's still currently not working.

#15 Noyce

    Rookie

  • The Money Maker
  • The Money Maker
  • 4 posts

Posted 06 August 2013 - 09:51 AM

still same problem, i am using google crome browser, as suggested by the web sight, and have updated java script , still same problem, and also having a RSS not loading error on opening patcher, i have contacted support. yet still no reply, and still cant give you my money.

#16 ShadowFacade

    Rookie

  • FP Veteran - Beta 1
  • FP Veteran - Beta 1
  • 7 posts

Posted 06 August 2013 - 10:04 AM

View PostMuggins, on 05 August 2013 - 04:20 PM, said:

We've had some forum/website issues over this long weekend; that said, it appears to be working normally right now. At time of writing, it's working for me and we see various successful transactions coming through.

If you're still unable to process your intended purchase please do contact support with some screenshots of where it is you are getting stuck.

Thanks
Muggins

Once again, it is an issue with the scripting of the public page. the script that results in pushing the button is
<a id="buyButton" href="javascript:void(0);">BUY NOW</a>

The "javascript:void(0)" is essentially saying that it returns an "undefined" response from the server. The reason that "void(0)" is used instead of "undefined" is because "undefined" is a variable and is able to be altered, thereby altering the function of the button. However, "void(0)" always returns an "undefined" response, essentially making the button a dead end in the page script.

#17 Thanatos676

    Member

  • PipPipPipPipPipPipPip
  • The Sickle
  • The Sickle
  • 703 posts
  • LocationTucson

Posted 06 August 2013 - 10:38 AM

This issue is not fixed and its still affecting people... please look into it again PGI..

using chrome and its telling me to get a better browser and i cant buy MC..

Edited by Thanatos676, 06 August 2013 - 10:39 AM.


#18 Kelane Windsword

    Rookie

  • 6 posts

Posted 06 August 2013 - 01:01 PM

I am also unable to buy MC. Same problem as everyone else.

#19 Thanatos676

    Member

  • PipPipPipPipPipPipPip
  • The Sickle
  • The Sickle
  • 703 posts
  • LocationTucson

Posted 06 August 2013 - 01:03 PM

Kelane, i found a workaround, try using HTTPS:// in front of Mwomercs.com

worked for me

#20 ShadowFacade

    Rookie

  • FP Veteran - Beta 1
  • FP Veteran - Beta 1
  • 7 posts

Posted 06 August 2013 - 02:27 PM

View PostThanatos676, on 06 August 2013 - 01:03 PM, said:

Kelane, i found a workaround, try using HTTPS:// in front of Mwomercs.com

worked for me


Thanks a ton Thanatos676, this does "fix" it. To the staff at PGI, please update all the links (on the site and in game) so people will stop getting the dead page. Thanks!

Edited by ShadowFacade, 06 August 2013 - 02:28 PM.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users