Jump to content

Patcher / Installer Feedback - 1.3.291


31 replies to this topic

#21 Fuzzbox

    Member

  • PipPipPipPipPipPip
  • 203 posts
  • LocationTerra

Posted 10 May 2014 - 11:06 AM

Some DNS issue?

#22 Oggelboggel

    Member

  • Pip
  • Shredder
  • Shredder
  • 14 posts
  • LocationSweden

Posted 10 May 2014 - 11:09 AM

View PostLan, on 10 May 2014 - 10:17 AM, said:

Likewise, I keep getting patch requests of 4 GB. After having performed patch, no problem gaming. Then shut it down, come back some hours later and wham.

"There is a new patch."

And I'm forced to patch again.


As an alternative to downloading 4Gb each time I want to play, i've adopted to changing the skipProxy value in the PatchBot.cfg file (located in the Bin32 folder).
If the launcher says there's a patch I change to skipProxy=1, save the file and restart the launcher.
I'll be prompted with an update notice at log-in, I change to skipProxy=0, save the file and restart launcher.
This time I'll be able to play. :)
Been doing this dance for the seven or so last sessions (since may 9th). Gave up on repair tool and support...

#23 G o a t

    Member

  • PipPip
  • 31 posts

Posted 10 May 2014 - 11:36 AM

This thing still persists. "Version mismatch"-4GB patch thing keeps coming up. Lame stuff...

#24 Fuzzbox

    Member

  • PipPipPipPipPipPip
  • 203 posts
  • LocationTerra

Posted 11 May 2014 - 10:16 AM

This is rediculus, I can't play.

#25 Coldblood

    Member

  • Pip
  • 13 posts

Posted 11 May 2014 - 01:08 PM

Same Version Mismatch after clean install

#26 MrJolly

    Member

  • PipPip
  • Philanthropist
  • 38 posts

Posted 11 May 2014 - 01:21 PM

I have this problem, too. Repair tool causes the 4Gb download and doesn't help.

What did help was using hosts file to select another mirror for patcher.mwomercs.com.

This IP doesn't work (patch required):

Quote

C:\Windows\System32>ping patcher.mwomercs.com

Pinging a1982.d.akamai.net [23.3.91.17] with 32 bytes of data:
Reply from 23.3.91.17: bytes=32 time=22ms TTL=55


This gets me thumbs up:

Quote

Pinging patcher.mwomercs.com [23.62.111.32] with 32 bytes of data:

Reply from 23.62.111.32: bytes=32 time=139ms TTL=42



(Note how it's on the other side of the world, more or less. I got the IP from a DNS viewing service.)


How to fix this for yourself temporarily:
1. Edit <windows dir>\system32\drivers\etc\hosts
2. Add the line:

Quote

23.62.111.32 patcher.mwomercs.com

3. Save file (you might have to change permissions, and Windows Defender might complain)
4. Restart launcher

(Note: Once real patches gets out, you will want to remove this, as it will slow down normal patching.)

Edited by MrJolly, 11 May 2014 - 02:07 PM.


#27 MrJolly

    Member

  • PipPip
  • Philanthropist
  • 38 posts

Posted 11 May 2014 - 02:51 PM

I poked around a bit with IPs reported from users, and a minute ago there were different responses to http://patcher.mwome...chInventory.txt depending on IP:

23.62.111.32 - lastest is 154
23.3.81.17 - latest is 154
23.3.90.235 - latest is 151

#28 panzerkunst99

    Member

  • PipPip
  • Survivor
  • Survivor
  • 20 posts

Posted 12 May 2014 - 12:53 AM

Same loop here:
Ive tried theese things, with following results:
Test 1
1 Ran the repairtool, it found some things missing, it re-downloaded those
2 Started game, it said, needed patch, the patch was the old patch so it would revert back to older version (not good)
3 I refused download patch, but exited launcher (patcher)
4 Result is maybe 1 of 10 times I run launcher it does not need patch.
5 If it does not need patch I then get to login screen
6 I log in here 9 of 10 times it say something in the style of wrong version, patch needed
7 I am back to first step, because the patch is the old patch

Test 2
1 I uninstalled mechwarrior and downloaded it again
2 Pretty much I get same result Launcher say I need patch (to older patch...)
5 If it does not need patch I then get to login screen
6 I log in here 9 of 10 times it say something in the style of wrong version, patch needed
Test 3
Wiped entire patcherlog folder - no effect

Further comments
By now I have run this repairtool 5 times it finds different errors each time
I managed to play some in one session on saturday, because by sheer luck i got past the launcher, patcher and login and game worked fine. Later in the evening i tried again but gave up, to slim a chance to get past all those obstacles. So bottom line, game works, butlooks like launcer or patcher is seriously flawed.

Needless to say 1, I think you guys have made an error here - no executable to bypass launcher and patcher, Like most other games? Now you guys have to check 3 possible errors - launcher, patcher and executable? Or even more? The repairtool is not working. Where is the file that say what version to patch too, because that seems to be whats messed up here.

Needless to say 2 - very disappointing this happens during x2 weekend, I just bought the firestarter hero ember on the sale and mechbay also on sale so I had hoped to get that up a bit.

Edited by panzerkunst99, 12 May 2014 - 12:53 AM.


#29 60CycleHum

    Rookie

  • 1 posts

Posted 12 May 2014 - 09:55 AM

Guys i got a problem... This is my first time installing MWO.. When i open the installer... it says downloading patch 1/1... i waited for like 3 + hours... still stuck in downloading patch 1/1 no file sizes/downloaded/internet speed n **** ... I Did everything run as admin - restart - delete - reinstall bla bla... still the same... Help is much appreciated.....

Edited by 60CycleHum, 12 May 2014 - 09:57 AM.


#30 Loosie

    Rookie

  • 7 posts

Posted 12 May 2014 - 10:43 AM

Got the same version mismatch and infinite patch-process/downloading. Editing patchbot.cfg provided a temporary workaround.

Edit: This was until today, when this workaround seems to have stopped working.

Edit #2: Using the mechwarrioronline flowthru from command promt to login. Got in alright, but dear devs; this is not good.

Edited by Loosie, 12 May 2014 - 11:03 AM.


#31 Brokolice007

    Rookie

  • 2 posts

Posted 12 May 2014 - 10:55 PM

Hello,

I have a problem with the installer client, I download a client and tried to install it but there's an error, the installer won't accept any other place for instalation other than C:\Program Files, if I choose custom instalation it pops up an error, so I can't install the game at all, and I already had the game installed and played it before, I don't know what changed, I have windows 8 64bit
I provided screenshot of the error message, I hope it helps

p.s. I also tried instlaling all the programs it mentioned in the log as absent, but I already have the same or newer version of them all

Posted Image

Edited by Brokolice007, 12 May 2014 - 10:57 PM.


#32 killenbigbugs

    Member

  • PipPip
  • Little Helper
  • Little Helper
  • 24 posts
  • LocationDawson creek BC, CANADA!!!!!!!~

Posted 16 May 2014 - 10:51 AM

Mismatch like everyone else, except i bought a computer after 2 years to finally play and can't :lol:





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users