Jump to content

Leo Podnar Bu0836A Not Recognised


6 replies to this topic

#1 mclang

    Member

  • PipPipPip
  • Big Brother
  • Big Brother
  • 93 posts

Posted 08 March 2018 - 12:38 PM

Hello.

I finally bought Leo Podnar BU0836A and modded my Thrustmaster T.Flight HOTAS X throttle. The throttle is visible on Windows, all twelve buttons and four axis work, but MWO doesn't see any them.

My other joystick which I use for aiming work allright.

Can anybody tell me what's wrong and help me get back to playing?


#2 NARC BAIT

    Member

  • PipPipPipPipPipPip
  • The 1 Percent
  • 499 posts
  • Twitch: Link
  • LocationAustralia

Posted 09 March 2018 - 05:03 PM

ummm I've really no idea, and apparently the joystick guys are not looking here .... have you heard of reddit .... its where all the cool internet trolls hang out these days .... anyway, theres at least a few other joystick guys there .... check out
https://www.reddit.c...re_looking_for/

#3 mclang

    Member

  • PipPipPip
  • Big Brother
  • Big Brother
  • 93 posts

Posted 10 March 2018 - 11:21 AM

So it seems :|

I have heard and read Reddit sometimes but not lot. Thanks for the tip, I will check it out.

#4 Gorantir

    Member

  • PipPipPipPipPipPipPipPip
  • Shredder
  • Shredder
  • 1,054 posts

Posted 11 March 2018 - 11:29 AM

did you assign values in the controller settings in the game settings?
be sure the axis are set to 'analog' throttle or 'analog' turn, not sure if theres an analog torso turn. im not in the game at the moment, does the game see them as joystick 0 and joystick 1? if you didnt reset the values it might be seeing the new circuit board in the hotas as a 3rd controller?

maybe you can use target or a keyboard emulator to assign a letter to a button then assign the letter to a game command..

I use a T16000m joystick and a Tflight Hotas x throttle myself

Edited by Gorantir, 11 March 2018 - 11:36 AM.


#5 mclang

    Member

  • PipPipPip
  • Big Brother
  • Big Brother
  • 93 posts

Posted 12 March 2018 - 11:25 PM

I tried to bind the axes and buttons in MWO but none are recognized.

I even tried with the warthog disconnected, the two unnecessary axes of the throttle disconnected and two other USB ports, but no luck.

When I previously used T.Flight HOTAS X throttle through its own joystick board, right hand warthog being joystick 0 and left hand throttle joystick 1, I got all working. I could assign analog throttle, analog turn and all the buttons of both controllers without any problem.

I also tested that I can assign buttons through AutoHotkey so I can work around them, but how to deal with the needed analog axes?

EvilC has Universal Joystic/Control Remapper done with Autohotkey, that maybe could be used to combine both joysticks as one, but problem is how can I then use my Warthog as mouse withm my absolute mouse aim script?

#6 mclang

    Member

  • PipPipPip
  • Big Brother
  • Big Brother
  • 93 posts

Posted 15 March 2018 - 11:03 PM

Hah, I finally found the problem!

For some reason it occurred to me that maybe MWO doesn't like the fact that the X and Y axes were NOT connected in the BU0836A chip. After connecting them to throttle and twist lever pots, MWO started to see all four axes and twelve buttons.

I'm all happy now Posted Image

#7 NARC BAIT

    Member

  • PipPipPipPipPipPip
  • The 1 Percent
  • 499 posts
  • Twitch: Link
  • LocationAustralia

Posted 16 March 2018 - 12:18 AM

persistence pays off, good work, let us know how well it all works out for you ...





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users