Jump to content

Problems With Logitech Mouse Button Assignment Performance Mx

1 reply to this topic

#1 marepinta


  • PipPip
  • Survivor
  • 28 posts
  • LocationSpokane Valley, WA, USA

Posted 22 December 2012 - 07:49 PM

We have three desktops in the game. One Win 7 pro, one XP pro, one Win 7 home.

the XP pro had no problems with mouse button assignments. this desktop was involved in closed beta and moved through with the same wired Logitech gaming mouse no problems.

Win 7 pro was next machine online. the same logitech mouse setup was used but it took awhile to get it set up right. We set keystroke assignments for each of the extra buttons and while they would work outside of the game in other programs, we tried all kinds of things before we finally got it right and they worked in-game. problem is we can't remember what all we did to make it work right. basic settings we copied from the XP machine ... not using Setpoint in-game, buttons programmed to specific keystrokes ['r', etc], worked fine out of the game [Word, etc] but took awhile before it worked. now it works great.

today trying to set up the Win 7 home machine playing. this mouse is Logitech Performance MX wireless. started using it with unifying receiver with keyboard and other mouse. uninstalled that and now using only single receiver for Performance MX by itself. We've tried keystroke settings, we've tried setting 4-9 buttons as 'generic buttons'. we started with only have typical 1,2,3 buttons working. now we have 1,2,3,4,5 working. this happened once we read on the forum and saw the suggestion for using 'generic button' vs. keystroke assignment. unfortunately we still cannot get 5-9 buttons working. we went back to keystroke assignment and they work fine outside of the game but will not 'press' within the option settings for the mouse in-game.

any ideas?

we have installed and uninstalled the setpoint several times, we tried 4.3 version and now are back to 6.51.8. we have it un-checked for using the setpoint within game, we are not using game specific settings. I did attempt game specific settings, but it says none of the buttons are available for custom mapping with mechwarrior within Setpoint.

much appreciation for any suggestions!!

#2 StainlessSR


  • PipPipPipPipPipPip
  • 443 posts
  • LocationSunShine State

Posted 24 December 2012 - 02:22 AM

open setpoint
goto Mouse game settings
  • select enabled
  • apply game settings when a game is detected
  • any speed or acceleration
  • do not select any of the keep button assignments
Click on advanced settings
  • select enable application-specific button settings
  • click configure
  • click add under select application
  • browse to c:\games\Prianah Games\MechWarrior Online\Bin32
  • select MWOClient.exe
  • click on select button and assign what you want that botton to do
  • click ok and exit out
While I do not have the gaming mouse this is how I setup my M510 to assign 3 and 4 to the page forward/back side button while in MWO.

Hope this helps.

If that does not work try going ingame to options and setting it ingame by pressing the button to assign it to the slot you want to assign it to

Edited by StainlessSR, 24 December 2012 - 02:25 AM.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users