Jump to content

Problems With My Headset. Any Suggestions?


6 replies to this topic

#1 Breeze

    Member

  • Legendary Founder
  • 83 posts
  • LocationMelbourne

Posted 28 November 2012 - 01:49 PM

I play MWO on my gaming laptop (a MSI GT783). I've had a sudden problem with my headset and I'm having some trouble figuring out the reason.

Prior to the problem, I hadn't installed any particular software to get the headset to work. Just plug in and use. However, in the past 2 days, there appears to be no input from the microphone (and the in-built mic is picking up my voice instead).

In the past week, I might have uninstalled a relevant program whilst fiddling around the control panel (I can't say for sure what the program I clicked on actually was, and whether it's related to audio at all. Careless, I know). I tried to restore my computer to an earlier point, but to no avail.

Currently, the laptop seems to recognise that a mic has been plugged in. Under the Sound menu, the mic shows up, and the green bars by the side light up when I plug the mic in and out. Speaking into it doesn't cause any reaction however.

I know that it's not very clear what exactly is wrong here. But looking for any suggestions on things I can try.

I will be testing out the headset itself, and also try to plug in another headset to test the mic jacks. But are there other things I should be testing out as well?

In trying to solve this issue, I did install the RealTek High Definition Audio Codec, which I believe was originally installed, and may have been the thing I had uninstalled.

Thanks for any assistance.

#2 Dawg

    Member

  • Veteran Founder
  • 155 posts
  • LocationSt Catharines, Ontario.

Posted 28 November 2012 - 02:00 PM

Maybe your mic is muted in one of the settings?

#3 Gremlich Johns

    Member

  • Legendary Founder
  • 3210 posts
  • LocationMaryland, USA

Posted 28 November 2012 - 02:10 PM

If it is USB.........

#4 Breeze

    Member

  • Legendary Founder
  • 83 posts
  • LocationMelbourne

Posted 28 November 2012 - 02:47 PM

View PostDawg, on 28 November 2012 - 02:00 PM, said:

Maybe your mic is muted in one of the settings?


I thought that it was perhaps my own stupidity. But I went through most settings, and it doesn't appear so.

View PostGremlich Johns, on 28 November 2012 - 02:10 PM, said:

If it is USB.........


No, it's not USB. I'm using the regular mic jack.

#5 madcatmike

    Member

  • Legendary Founder
  • 34 posts

Posted 29 November 2012 - 04:44 PM

Go into your control panel then sound. Make sure that your headset is set as your default recording device. Sometimes, if you unplug a mic, windows will automatically revert to the build in solution.

I'd give a more through walkthrough but I'm at work and don't know which version of Windows you're using.

#6 Gremlich Johns

    Member

  • Legendary Founder
  • 3210 posts
  • LocationMaryland, USA

Posted 30 November 2012 - 05:55 PM

laptop, gah.

could be a few things. bad cable? sound software reload/update? box checked that should not be? (like madcatmike suggests) Properties indicate drivers disabled? Gone into teamspeak to see if you can talk there and nowhere else? (I have to do that latter bit every now and then). check the headset on another system? If that doesn't work, bad cable.

Edited by Gremlich Johns, 30 November 2012 - 05:59 PM.


#7 Sen

    Member

  • Legendary Founder
  • 757 posts
  • LocationTexas

Posted 01 December 2012 - 06:42 AM

If you uninstalled the sound driver it may have reset the default device/default COMMUNICATIONS device. it is probable that the mic has defaulted to the built in mic on the laptop. [as you stated]

Right click on the sound icon in the tray and select recording devices. Right click on the one YOU WANT TO USE and set it to default COMMUNICATION device. if you're not sure which one is which, try the one that's NOT already set to default.

then test it. If you're not sure which one is the mic jack, try them all in sequence until you find the right one.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users