Jump to content

[Cw Api] Planets Changes?


7 replies to this topic

#1 Shlkt

    Member

  • PipPipPipPipPipPip
  • Ace Of Spades
  • Ace Of Spades
  • 319 posts

Posted 17 March 2015 - 01:08 PM

Today, March 17th, at some time after 14:30 UTC a large number of planets disappeared from the community warfare map data provided by the API. The planets do not appear to be missing in-game.

Examples for reference:

http://static.mwomer...3-17T14-30.json - 1855k, contains 2240 planets
http://static.mwomer...3-17T18-15.json - 928k, contains 1120 planets

Any idea what's going on? The CW API does not appear to match the in-game map viewer.

#2 Krivvan

    Member

  • PipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 4,318 posts
  • LocationUSA/Canada

Posted 18 March 2015 - 01:36 AM

Looks like it's still missing planets.

#3 Noesis

    Member

  • PipPipPipPipPipPipPipPipPip
  • Legendary Founder
  • Legendary Founder
  • 4,431 posts
  • LocationIn the Lab

Posted 18 March 2015 - 05:21 PM

Still broke.

Also the Clans will be even more inspired to try and reach Terra now that reports of their home world Strana Mechty has vanished from these communication reports.

#4 Krivvan

    Member

  • PipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 4,318 posts
  • LocationUSA/Canada

Posted 18 March 2015 - 10:24 PM

Still broken PGI.

#5 Toadflakz

    Member

  • PipPipPipPipPip
  • The 1 Percent
  • The 1 Percent
  • 116 posts

Posted 19 March 2015 - 08:22 AM

Were these planets actually used? Has anyone done a diff between the old planets and the new ones?

I started work on a custom map visualisation and realised that there are many, many planets included that are not part of the main Inner Sphere. It could be that these peripheral planets (of which there were hundreds) have been removed.

#6 Banditman

    Member

  • PipPipPipPipPipPipPipPipPip
  • Ace Of Spades
  • Ace Of Spades
  • 2,109 posts
  • LocationThe Templars

Posted 19 March 2015 - 10:02 AM

Ah - no. Many of them were "owned" by various groups. For instance, if I go in game, my unit has like 12 or so planets, but the data being parsed out from the API shows us with only 5 or 6.

#7 Krivvan

    Member

  • PipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 4,318 posts
  • LocationUSA/Canada

Posted 19 March 2015 - 02:11 PM

View PostToadflakz, on 19 March 2015 - 08:22 AM, said:

Were these planets actually used? Has anyone done a diff between the old planets and the new ones?

The planets were including the ones being attacked, otherwise it wouldn't have been as much of an issue.

Should be getting fixed now though:
@Zeece_MWO @russ_bullock I have fixed the API and the 12:15 data dump will have all the planets. #fixedAPI

#8 Toadflakz

    Member

  • PipPipPipPipPip
  • The 1 Percent
  • The 1 Percent
  • 116 posts

Posted 19 March 2015 - 10:33 PM

Okay, cool. Just checking as it could've been optimisations to fix that algorithm that Paul has been giving lollipops to when it works after it became self-aware sometime last week. ;)





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users