Jump to content

Black Screen On Startup


13 replies to this topic

#1 Bionic Crow

    Rookie

  • Survivor
  • 1 posts

Posted 12 December 2015 - 04:45 PM

So recently I started playing MWO. I loaded the game up today and found out that it just showed a black screen and stopped responding. I've looked for solutions but i've found none. Any help would be appreciated. Thanks in advance!

#2 Dawnstealer

    Member

  • PipPipPipPipPipPipPipPipPip
  • Mercenary
  • Mercenary
  • 3,734 posts
  • LocationBlack Earth

Posted 12 December 2015 - 10:43 PM

I've been playing this for a long, long time and kind of have a similar problem. Reinstalled the client, run the patcher, no change. I can hear the startup animations, but can't see them.

Thankfully, unlike the new player above, I know the timing and sounds of the startup screen, so can just enter my password without actually being able to see it, and the game fires up as normal. But if I were a new player? There'd be no way I'd know what was going on.

#3 TWIAFU

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Pest
  • The Pest
  • 4,011 posts
  • LocationBell's Brewery, MI

Posted 13 December 2015 - 06:25 AM

View PostBionic Crow, on 12 December 2015 - 04:45 PM, said:

So recently I started playing MWO. I loaded the game up today and found out that it just showed a black screen and stopped responding. I've looked for solutions but i've found none. Any help would be appreciated. Thanks in advance!



Sounds familiar.

What I did to fix that is three steps, and all can be found on the Microsoft website;

Download, install as admin, the following;

1. vcredist_x86
2. vcredist_x64
3. dxwebsetup

#1 and #2 here: https://www.microsof...s.aspx?id=40784
#3 here: https://www.microsof....aspx%3Fid%3D35

Next, run the Client. Before you hit PLAY, upper right corner, look for a pair of cogs, click it and select Force 32b Client.

Now click Play. IF the same issue I have run across, it should have Launched. Go to settings right away, and choose DX9 and save. Restart if asked.

Now, launch and see if everything is working. Play a match. If everything looks good and is working, you can choose to go back to settings and change DX setting to auto or whatever your rig supports. Save any changes and will have to restart client. Can change back to 64b client if it is supported.

Hope this helps and gets you on your way.

#4 Locked

    Rookie

  • 5 posts

Posted 13 December 2015 - 08:12 AM

Thanks TWIAFU it helps one of my friends to finally launch a game Posted Image

#5 DAEDALOS513

    Member

  • PipPipPipPipPipPipPipPipPip
  • @ui_title_%s_Rank_6
  • @ui_title_%s_Rank_6
  • 2,435 posts
  • LocationArea 52

Posted 07 June 2016 - 04:03 PM

Running repair tool fixed this issue right away.

#6 Aleksandr Sergeyevich Kerensky

    Member

  • PipPipPipPipPipPipPipPip
  • 1,176 posts

Posted 07 June 2016 - 05:56 PM

Upon reading the original post as well as those after the first...

I can only conclude that this is a L2P issue!

(Ok sorry... Bad troll is a bad troll... My bad!)

#7 Master Maniac

    Member

  • PipPipPipPipPipPip
  • Survivor
  • Survivor
  • 373 posts
  • LocationKentucky, United States

Posted 08 June 2016 - 11:33 AM

Topic is old as heck, but it's a new issue for me. Haven't played for a while, but since the latest patch I can't start the game. It black-screens and locks the computer, forcing a hard restart.

#8 DAEDALOS513

    Member

  • PipPipPipPipPipPipPipPipPip
  • @ui_title_%s_Rank_6
  • @ui_title_%s_Rank_6
  • 2,435 posts
  • LocationArea 52

Posted 08 June 2016 - 12:17 PM

View PostMaster Maniac, on 08 June 2016 - 11:33 AM, said:

Topic is old as heck, but it's a new issue for me. Haven't played for a while, but since the latest patch I can't start the game. It black-screens and locks the computer, forcing a hard restart.

My black loadup screen just came out of nowhere.. not really after any patch. I tried 4-5 times to start the game only to see the same black screen. All I did was run the repairtool and it fixed it.

#9 Master Maniac

    Member

  • PipPipPipPipPipPip
  • Survivor
  • Survivor
  • 373 posts
  • LocationKentucky, United States

Posted 09 June 2016 - 12:49 PM

View PostDAEDALOS513, on 08 June 2016 - 12:17 PM, said:

My black loadup screen just came out of nowhere.. not really after any patch. I tried 4-5 times to start the game only to see the same black screen. All I did was run the repairtool and it fixed it.


I appreciate the suggestion. There's definitely no harm in trying. Since I'm on the Steam version, I guess the equivalent would be "verify game cache." If I get a positive result, I'll post about it here in case anyone else is still having this issue.

#10 T1tanium

    Member

  • Pip
  • Legendary Founder
  • Legendary Founder
  • 17 posts
  • LocationGermany

Posted 24 July 2017 - 10:49 AM

View PostDAEDALOS513, on 08 June 2016 - 12:17 PM, said:

My black loadup screen just came out of nowhere.. not really after any patch. I tried 4-5 times to start the game only to see the same black screen. All I did was run the repairtool and it fixed it.

I had this issue 4-5 times the last 12 months. But after the latest patch, it's just a black screen and locks up my pc. The repair tool didn't find any issues. Also deleted the game.cfg with the repair tool but no help.
It's very sad my premium time is running up because it's not banked any more with standard mech paks.
Maybe I try the solution from Twiafu, but I don't know if that is still valid.
Every help is appreciated.

#11 T1tanium

    Member

  • Pip
  • Legendary Founder
  • Legendary Founder
  • 17 posts
  • LocationGermany

Posted 24 July 2017 - 11:02 AM

delete the profile folder and start the game.
Have fun in the settings *again*....

#12 jagzed

    Rookie

  • 6 posts

Posted 23 August 2018 - 12:46 PM

2018. This bug happens to me if I set my resolution to 1920 x 1080 and full screen. The display goes black right after entering the login details. Pressing Alt + Enter doesn't help, but when I press it a second time I can see the very edge of the game appear on my second display, while the main display remains black.

Solution for me was to delete the profile and then set the game to 1680 x 1050. I would like to play at the higher res as my computer specs support it.

Edited by jagzed, 23 August 2018 - 12:53 PM.


#13 Wanderer of the Mists

    Member

  • PipPipPip
  • Legendary Founder
  • Legendary Founder
  • 89 posts
  • LocationAlabama UAS

Posted 26 December 2018 - 03:29 PM

I've recently had the same problem I've followed all the steps above and reset everything at this point I'm still having this issue. I'm reinstalling my Nvidia Geforce GTX970m drivers but I'm not hopeful as thats what I did before I had to reinstall windows. Nope no change.

Edited by Warden of Reason, 26 December 2018 - 03:56 PM.


#14 TheCaptainJZ

    Member

  • PipPipPipPipPipPipPipPipPip
  • The God
  • The God
  • 2,859 posts
  • LocationUnited States

Posted 28 December 2018 - 01:13 PM

View Postjagzed, on 23 August 2018 - 12:46 PM, said:

2018. This bug happens to me if I set my resolution to 1920 x 1080 and full screen. The display goes black right after entering the login details. Pressing Alt + Enter doesn't help, but when I press it a second time I can see the very edge of the game appear on my second display, while the main display remains black.

Solution for me was to delete the profile and then set the game to 1680 x 1050. I would like to play at the higher res as my computer specs support it.

Try Full Windowed mode. Fullscreen has always been a bit buggy with black screens and crashing and when using alt+tab. Ever since I switched to full windowed mode, I've had zero of those issues.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users