Jump to content

Stuck Point On Tourmaline Desert Domination Mode

No replies to this topic

#1 Anachronda


  • PipPipPipPipPipPip
  • Bridesmaid
  • 291 posts

Posted 30 January 2018 - 03:48 AM

This was during Faction Play / Community Warfare. I tried to jump the wall, but came just short and fell down between the wall and one of the formations.


You might think I could have used jump jets to get back out of that hole. Unfortunately for some reason my jump jets wouldn't refuel/regenerate in that spot. At least not more than a little bit. I think it has something to do with how I was sliding around there. They'd refill a little then deplete as I recall. I tried to jump anyhow, but couldn't get unstuck. I have a video of that, but it is kind of big.

You can see the coordinates in the screenshot I took. I turned in every direction I could, but could not get loose or jump out of the spot. I tried wiggling around, feathering the jets, everything I could think of. In the end the only choice I had was ejecting.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users