Jump to content

Mwo Portal Already Installed


3 replies to this topic

#1 Nicksy129r

    Rookie

  • The Raider
  • The Raider
  • 1 posts

Posted 16 March 2018 - 02:09 PM

Hi all,
So I've got a very unique problem. I've email MWO about the problem but its been a week and I'm still waiting for a reply so I thought I might post to the Forums since I can't be the only person who's had this problem.

So I had MWO installed on my J portable hard drive.. which I dropped. The hard drive is officially out of actions so obviously I have to reinstall MWO. Problem is when I go to install the MWO Portal Installer it says "MWO Portal is already installed". Huh... that's odd...
So I go to the Control Panel and sure enough, there's MWO Portal.... on my J portable hard drive... which isn't plugged in... I go to uninstall it and it replies "Invalid drive" and won't uninstall.

I've looked around on the net and even tried deleting the registry which contains MWO info but nope. I've managed to delete it as far as Control Panel can't find it to uninstall but MWO Portal Installer still says "MWO Portal is already installed" so I don't know what else I can do.

I'd love to not have to put my computer back to factory default and I'm hoping there's just one more file/registry/etc I have to delete to get it working cus I'm getting withdraw symptoms since I haven't played in a while now, ha ha.

Thanks for any suggestions or replies,

#2 Tarl Cabot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Tai-sho
  • Tai-sho
  • 6,757 posts
  • LocationImperial City, Luthien - Draconis Combine

Posted 16 March 2018 - 02:52 PM

https://support.micr...lled-or-removed

You will want to uninstall both MWO Portal and Mechwarrior Online.

https://turbofuture....stall-a-program

There are 3rd party programs that can assist you.

Edited by Tarl Cabot, 16 March 2018 - 02:55 PM.


#3 JunkoSuzuki

    Rookie

  • Bridesmaid
  • 1 posts

Posted 25 March 2020 - 12:32 AM

Thank you!

#4 Tarl Cabot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Tai-sho
  • Tai-sho
  • 6,757 posts
  • LocationImperial City, Luthien - Draconis Combine

Posted 26 March 2020 - 07:56 AM

Even though the thread is 2 years old, still helpful, and some additional information from a recent thread.

Also for one player in a similar situation, harddrive failure, and even after jumping through several hoops, with the Windows 10 assistance and also removing entries for MWO or Mechwarrior from the registry, he still could not install the client again since the registry said it was already installed.

He was able to reinstall it after searching the registry for "piranha" and deleting the folder.

https://mwomercs.com...-drive-failure/

Edited by Tarl Cabot, 26 March 2020 - 07:57 AM.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users