Jump to content

Can't Enter Specific Thread

No replies to this topic

#1 Saint Dane Icaza


  • Pip
  • Bad Company
  • Bad Company
  • 11 posts

Posted 28 May 2018 - 10:40 AM

Hi, I can't enter the "Mech Fashion Contest" (https://mwomercs.com...ashion-contest/) thread whatsoever while logged in.

Yesterday it was working fine. I posted my screenshots for the contest, but the loading was taking too long and I thought it was broken, so I closed out the window and decided to try again later.

12 hours ago, I tried again and realized that the webpage literally just won't load. Also, the thread while looking at the thread list in "Announcements" has a black background, while all the others are gray.

I've tried clearing my cache and trying different browsers and devices but it won't go away. The only way to enter the thread is to log out, and of course I can't post. So now I won't be able to enter the contest. Does anybody have any idea what's happened?

Edited by Saint Dane Icaza, 28 May 2018 - 12:34 PM.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users