Jump to content

That Happened For What Reason?


4 replies to this topic

#1 Celthora

    Member

  • PipPipPip
  • Ace Of Spades
  • 95 posts
  • LocationTurkey

Posted 11 March 2019 - 03:18 AM

I bought an ati rx 580 graphics card, the game was extremely smooth on high settings for 2 days. Now I can join game after ready check ends and fps is impossible to play, under 10 even in low settings.
Huh? Should I reinstall or something?

Note: It happened while I play 1v1 straightly. One match was ok, then next match it started agonizing. I thought it'll be fixed when I restart pc but no...

Note2: Other games have no problem.

Edited by Celthora, 11 March 2019 - 04:03 AM.


#2 Tarl Cabot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Tai-sho
  • Tai-sho
  • 7,000 posts
  • LocationImperial City, Luthien - Draconis Combine

Posted 11 March 2019 - 05:05 AM

Too many factors.

Power Options, set to High Performance.

Double check connections and wiring, ensuring everything is seated properly and wiring is not getting hung up anywhere. Also on the CPU make sure dust buildup has been cleared out from the heat sink.

No need for a game reinstall. Run the repair tool and select everything. That will remove your game settings and put them back to default.

#3 G B Vandenburg

    Rookie

  • The Blood Bound
  • The Blood Bound
  • 5 posts
  • LocationThunder Bay, Ontario, Canada

Posted 11 March 2019 - 05:19 AM

Here is what most likely happened:

"Microsoft has acknowledged new issues with the optional update for Windows 10 version 1809 released last week. The build 17763.348 (KB4482887), which is only available for Windows 10 users checking for updates in Windows Update, brought quite a long list of fixes, but there’s one issue that’s apparently causing performance drops in many PC games."

See if you have that patch installed, then uninstall that update... see if that fixes. If you DON"T have that patch, or uninstalling that patch does not fix, then is something else.

GBV

Edited by G B Vandenburg, 11 March 2019 - 05:23 AM.


#4 Celthora

    Member

  • PipPipPip
  • Ace Of Spades
  • 95 posts
  • LocationTurkey

Posted 11 March 2019 - 10:05 AM

LoL resolved. How lame, it was because I set power settings to save mode in control panel... I thought it was only about turning monitor and hard disc off after a specific time passes.

Edited by Celthora, 11 March 2019 - 10:08 AM.


#5 D V Devnull

    Member

  • PipPipPipPipPipPipPipPipPip
  • Knight Errant
  • 3,111 posts
  • LocationAnywhere but here, and the lights in my bays are off.

Posted 11 March 2019 - 10:39 AM

View PostCelthora, on 11 March 2019 - 10:05 AM, said:

LoL resolved. How lame, it was because I set power settings to save mode in control panel... I thought it was only about turning monitor and hard disc off after a specific time passes.

If you explicitly need those two features (Power Saves for Monitor & Hard Disk) out of the whole Power control setup, then you'll have to make a Custom Profile for doing that. MWO literally HATES any feature that throttles down CPU/GPU/RAM, and may even give you grief over trying to throttle down the Hard Disks as well. :(

By the way, Tarl Cabot didn't mention it... But, don't forget to clear dust from your GPU's Heat Sinks & Fans, so that it doesn't choke down at high temps. :huh:

Oh, and do NOT ever let Windows Update mess with your Driver Files on your computer. Allowing such could land you in a world of hurt where NO game is playable, particularly MWO with how that's sensitive to even the slightest Driver Changes on a computer. I've heard that happen to a few too many people, and it wasn't fun helping them pin it down. :o

~D. V. "has a deep-seated hatred over Micro$oft taking someone's Real $$$ and screwing them over" Devnull





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users