Jump to content

W Key Stops Working, Only Solution, But Can't Find The Cause


2 replies to this topic

#1 Xaat Xuun

    Member

  • PipPipPipPipPipPipPip
  • The Defender
  • The Defender
  • 717 posts
  • LocationA hypervelocity planet

Posted 07 June 2019 - 10:30 AM

MWO is not the only game this has happen in

TLDR: the W key won't work for the throttle forward sometimes, repair tool seems to fix it, but the problem comes back after a while, W key works in text, but not for the throttle
-=-=-=-=-=-=-=-=-=--=-=-=--=-=-=--=--=--=-=-=-

W key seems to not work, my first thought was broken key, this also happens in another game but yet I can type any word with the "W" in it, so it's not like it is not working period, just not for the forward throttle.
I've had this happen in another game, but that game sometimes will have a popup telling me something is wrong, would i like to run the repair tool (something like that), sometimes I do, sometimes because I really don't see the problem (we'll come back to that)
I have unplugged and plugged device, updated software, would have used another keyboard, have plenty, just in the middle of moving, and they're still in storage (600mile drive just for a keyboard not worth it) buying another even if it was cheapest out there, seemed unpractical, when I already have close to half a dozen keyboards.
so for the mean time I was just dealing with it when the problem arise press 0 key for forward

Then last effort of think how to solve this, the thought occur to me, the other game I do run the repair tool since the popup happens when I start the launch, and as mentioned sometime run, and I don't always have the 'w' key issue, so this time I run the repair tool, and now 'W' key works as intended.

this problem started at the beginning of the this year, I couldn't recall exact month but Jan or Feb

being the 2 games I play are totally different, this may be a Windows 10 thing, or possibly both games do have the same issue. Guess I could check windows history and see if there was an update around that time,
AHh shoot, just recalled, . . there was also a 3rd game it happens too, I'm not going back to edit and add 3 games I play instead of the "2 games"

when I run the repair tool, it does not list any issues, just it's going to remove some thing, and and clear a cache, I can run the repair tool back to back, and see the same list for fix, remove something (bad memory, no screen shot so can't remember) and that Cache, I think it's like 4 things listed for the action when I press fix button


-=-==--=-=-=-=-=-=--=


thought I would mention this, so if any others have similar problem and know a fix, where repair tool is not required anymore to solve

it's just weird, "W" works in text, but not going forward

#2 Tarl

    Rookie

  • 5 posts

Posted 07 June 2019 - 03:00 PM

Which Windows?
View Update History to see if Windows updated Keyboard software/driver
Brand/model Keyboard
Specific software installed for keyboard?
Uninstall and reinstall newest keyboard drivers.
Input language set to US-English

By default Windows 10 is setup to download/install drivers /shudders...

Also, do you play in Full Screen or a Windowed mode? Multiple key presses may be causing game to temp lose focus or multiple key presses (or a previous key press not being released) causing system to not recognize the individual key stroke but as part of a multi-key /combination key stroke.

Also tilt keyboard and smack/clear any possible debris that might be residing under the key.

#3 OZHomerOZ

    Member

  • PipPipPipPipPipPipPipPip
  • Little Helper
  • 1,977 posts

Posted 10 July 2019 - 12:25 AM

Change the xml file with your key bindings to read only perhaps, Not great but it should stop them changing

If you overclock, could be a little well done causing data to corrupt, Plus I hear is pretty hot in the northern hemishpere this time of year. Heat can affect PC stability when overclocked or stock PC with birds nesting (dust) in CPU Heatsink





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users