Jump to content

Mwo Site Data Breach


6 replies to this topic

#1 OP8

    Member

  • PipPipPipPipPip
  • Big Daddy
  • Big Daddy
  • 121 posts

Posted 11 March 2020 - 08:31 AM

Every time MWO asks me to sign in, Chrome gives me a message box saying that mwomercs.com has revealed my credentials in an unsecure manner and that I should change all my passwords as a precaution. This is the only site that generates that response.

#2 JediPanther

    Member

  • PipPipPipPipPipPipPipPipPip
  • Legendary Founder
  • Legendary Founder
  • 3,462 posts
  • LocationLost in my C1

Posted 11 March 2020 - 08:57 AM

Try different browser. Firefox has no issues with the web site. Pretty sure if there was such an issue as a data breach pgi support would have sent an e-mail out. Pgi sucks on a lot of things but their support is good.

#3 Horseman

    Member

  • PipPipPipPipPipPipPipPipPip
  • CS 2019 Top 8 Qualifier
  • CS 2019 Top 8 Qualifier
  • 3,093 posts
  • LocationPoland

Posted 11 March 2020 - 08:59 AM

I am not getting such a message from Chrome.
What you're writing sounds more like a problem with the SSL encryption between you and the site.
Screenshot of the exact error message, please. No cropping, if there's any sensitive/personal information please block it out instead.
Also, what's your OS?

Edited by Horseman, 11 March 2020 - 09:00 AM.


#4 VonBruinwald

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Undisputed
  • The Undisputed
  • 2,486 posts
  • LocationRandis IV

Posted 11 March 2020 - 10:33 AM

View PostHorseman, on 11 March 2020 - 08:59 AM, said:

I am not getting such a message from Chrome.
What you're writing sounds more like a problem with the SSL encryption between you and the site.
Screenshot of the exact error message, please. No cropping, if there's any sensitive/personal information please block it out instead.
Also, what's your OS?


Also, a list of installed extensions. Some of them can be a man in the middle.

#5 Nearly Dead

    Member

  • PipPipPipPipPipPip
  • Philanthropist
  • 257 posts

Posted 12 March 2020 - 01:37 AM

I had a similar problem after an update to IQue, the Corsair headset software. Not identical, because it was other sites where I got the warning about site security. Finally wiped Windows 10 and got rid of it, but did not use the IQue software, now I just use the windows sound controls.

#6 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,308 posts

Posted 14 March 2020 - 10:59 AM

i use chrome and i dont get this. check your extensions. sounds like you got adware. this reads like an internet security software ad.

#7 Tarl Cabot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Tai-sho
  • Tai-sho
  • 6,896 posts
  • LocationImperial City, Luthien - Draconis Combine

Posted 14 March 2020 - 11:14 AM

View PostVonBruinwald, on 11 March 2020 - 10:33 AM, said:


Also, a list of installed extensions. Some of them can be a man in the middle.

View PostLordNothing, on 14 March 2020 - 10:59 AM, said:

i use chrome and i dont get this. check your extensions. sounds like you got adware. this reads like an internet security software ad.


This. Logging in via Chrome on 2 different computers do not generate said message.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users