Jump to content

Logitech Setpoint And Mouse Buttons

9 replies to this topic

#1 someth1ng


  • 1 posts

Posted 04 December 2012 - 06:20 PM

Hello everyone!
I found already a topic which is indirectly touching the subject, but just wanted to rise the flag to developers and users: Mechwarrior Online is the only game I was able to find so far, which is ignoring keystroke assignments for additional mouse buttons in Logitech SetPoint.
You see, mouse from Logitech MX5500 revolution set has at least 8 additional "buttons" which are very convenient to use in "non-trivial" games :). Of course by default they are not supported, but you can assign them regular keyboard combinations. For example make "quick search" button produce keyboard "F" button signal, or "Ctrl+G" , or "F1". But they just don't work in MWO.
And that's sad.

Edited by someth1ng, 04 December 2012 - 06:21 PM.

#2 Tarl Cabot


  • PipPipPipPipPipPipPipPipPipPip
  • 5,725 posts
  • LocationImperial City, Luthien - Draconis Combine

Posted 06 December 2012 - 06:14 AM

Try turning off Setpoint.

#3 Sen


  • PipPipPipPipPipPipPip
  • 757 posts
  • LocationTexas

Posted 06 December 2012 - 06:44 AM

Must be something weird Logitech does with their hardware/software.

My razer naga has no problems. I do not use ANY of the razer software either.

#4 Bloodshed Romance


  • PipPipPipPipPipPipPip
  • Legendary Founder
  • Legendary Founder
  • 726 posts
  • LocationFlorence, South Carolina

Posted 08 December 2012 - 10:52 AM

I use a Logitech G700 with logitech setpoint... just set the extra mouse buttons with macros for 3 4 5 6 is what I did for the 4 thumb buttons... works amazingly..

so left click is group 1, right click is group 2, then the 4 side buttons are 3 4 5 6... problem solved???

EDIT if your mouse supports multiple profiles then you can create a dedicated MWO profile for the macro combinations... might help if you use the mouse buttons for everyday web browsing or something?

Edited by Bloodshed Romance, 08 December 2012 - 10:53 AM.

#5 Capn Cat


  • PipPip
  • The Predator
  • The Predator
  • 22 posts

Posted 25 February 2013 - 10:41 PM

Hi, perhaps I shouldn't resurrect this old thread, but this is the first google result for this issue.
I created a small bat file which will end the setpoint process for you.
If you put it with the game shortcut it might help you remember to quit setpoint before you get into a brawl and wonder why your Las0rs won't fire.

the .bat file can be found here:

its nothing dodgy, just a command line - right click it and choose edit if you want to see how it works.
it is also possible to launch mw with this app, just right click the file -> edit, and then add these lines after the existing text

cd [path to bin32 directory in mechwarrior online directory] (without brackets)
for example if you installed in the default location it will be
cd C:/Games/Piranha Games/MechWarrior Online/Bin32/

then type
start MechWarrior Online.exe

Then save the file. When run, it should now kill setpoint and then load mwo

Your extra buttons on your mouse should still function without setpoint running

Edited by cpncodpiece, 25 February 2013 - 11:16 PM.

#6 evilC


  • PipPipPipPipPipPipPipPip
  • Legendary Founder
  • Legendary Founder
  • 1,297 posts
  • LocationLondon, UK

Posted 26 February 2013 - 07:46 AM

Setpoint works fine with MWO.
There are two ways of acheiving this:
1) Make the mouse use the default game controls:
Leave MWO config as it is. In SetPoint, change the mouse button to hit the relevant keyboard key.
I have a G700 and it works fine. I also have a MX620 which also works fine.

2) Make the game recognise the mouse buttons.
In SetPoint, change the mouse button that you wish to use to "Generic Button" or "Generic Button x" (eg "Generic Button 4").
In MWO, bind your control to that mouse button.

Failing that, try AutoHotkey.
Install AutoHotkey, create a new text file called "test.ahk" and edit it. Paste the following code in:

SetKeyDelay, 0, 50

This should make the middle mouse button fire weapon group 3.

#7 Lusankya


  • PipPipPipPipPipPip
  • Urban Commando
  • Urban Commando
  • 266 posts
  • LocationSaskatchewan

Posted 26 February 2013 - 08:18 AM

No problems using setpoint although I'm only using a basic 3 button mouse (left, right, and middle clicking wheel). I actually had to use setpoint to get the middle button to work properly.

#8 Capn Cat


  • PipPip
  • The Predator
  • The Predator
  • 22 posts

Posted 26 February 2013 - 08:37 PM

View PostevilC, on 26 February 2013 - 07:46 AM, said:

Setpoint works fine with MWO.
There are two ways of acheiving this:

Now there are three ways :rolleyes: But I woudn't say it works fine...
If you use option one I presume you have to make a profile which detects when MW is launched? Otherwise changing my mouse settings every time I want to play is far more tedious than just quitting setpoint.
Option 2 I have already seen suggested and tried, it didn't work for me - I'm using an m705 (great little mouse btw), a side issue is I haven't managed to get the thumb squeeze button to work in any way, as applications don't seem to recognize it as a button push.

View PostLusankya, on 26 February 2013 - 08:18 AM, said:

No problems using setpoint although I'm only using a basic 3 button mouse (left, right, and middle clicking wheel)

Yes, the basic three buttons will work with setpoint - my mouse has a forward and back thumb button which I use for weapon groups 3 and 4.

[edit] english

Edited by cpncodpiece, 26 February 2013 - 08:53 PM.

#9 Garbagecan


  • PipPip
  • 33 posts
  • LocationFace down in a sewer drain somewhere on Outreach

Posted 01 March 2013 - 03:03 PM

I actually am having a similar problem with a new g500. I'm not sure if the mouse is defective or not. I assigned the generic buttons to keystrokes in my set point profile for Mechwarrioronline. The middle thumb button and the wheel don't seem to be doing anything. Also, the mechwarrior config screen seems to have assigned tasks to them already. I'm going to test it out some more still.

#10 Omaha


  • PipPipPipPipPipPipPip
  • The Blood-Eye
  • The Blood-Eye
  • 531 posts
  • LocationAnywhere

Posted 20 April 2013 - 12:20 PM

Just experienced a crash from using extra buttons on my mx revolution, I think it may be due to setpoint. I need to have set point to use my buttons =[

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users