Jump to content

Frozen City Textures Missing


13 replies to this topic

#1 Lubalin

    Member

  • Members
  • PipPipPip
  • 52 posts

Posted 04 February 2014 - 09:15 PM

New to this patch.

Turning on vsync put them back.

#2 Spunkmeyer

    Member

  • Elite Founder
  • 71 posts
  • LocationChicago IL, cReddit Merc Corp

Posted 04 February 2014 - 09:32 PM

Thanks for the tip, I'll have to try this. Also experienced missing textures on this map since this new patch.

#3 Ellen Ripley

    Member

  • Legendary Founder
  • Phoenix Overlord
  • Phoenix Overlord
  • 196 posts
  • LocationLV-426

Posted 05 February 2014 - 02:06 AM

While it seems to have affected you and some other people for the first time with the implementation of this patch, this particular bug has been around for month now, apparently without being adressed by PGI. There is also a version of it where the textures are constantly switching between being gone and then reappearing.
The workaround you described (turning on vsync) so far has helped in evey case I heared about (for both versions of this bug btw.).

#4 1Sascha

    Member

  • Members
  • PipPipPipPipPipPip
  • 401 posts
  • LocationMunich, Germany

Posted 05 February 2014 - 02:12 AM

It's not a new bug. I've been getting this for ages.

Then someone pointed out the "enable VSync"-workaround to me, which actually cured it.


S.

#5 Albert Meyburgh

    Systems Engineer

  • Staff
  • 74 posts
  • Location404

Posted 06 February 2014 - 02:40 PM

vsync makes the shaders rebuild so it's probably related to a bug we've been tracking regarding the game getting corrupt during async shader compilation. we're possibly turning off async shader compile when dx11 is released but it's not my dept so I'm not sure. In the meanwhile if you delete your user shader cache, run the repair tool, and add r_ShadersAsyncCompiling=0 to your user.cfg it MAY resolve the issue but no promises for now ;)

#6 Ellen Ripley

    Member

  • Legendary Founder
  • Phoenix Overlord
  • Phoenix Overlord
  • 196 posts
  • LocationLV-426

Posted 07 February 2014 - 02:19 AM

Thanks for that info, highly appreaciated! :angry:

#7 1Sascha

    Member

  • Members
  • PipPipPipPipPipPip
  • 401 posts
  • LocationMunich, Germany

Posted 07 February 2014 - 03:25 AM

View PostAlbert Meyburgh, on 06 February 2014 - 02:40 PM, said:

vsync makes the shaders rebuild so it's probably related to a bug we've been tracking regarding the game getting corrupt during async shader compilation. we're possibly turning off async shader compile when dx11 is released but it's not my dept so I'm not sure. In the meanwhile if you delete your user shader cache, run the repair tool, and add r_ShadersAsyncCompiling=0 to your user.cfg it MAY resolve the issue but no promises for now :angry:


Tried that before (all except the added user-cfg-line). While this would cure it temporarily, the bug would always return for me. Enabling VSync seems to have cured it for good.

What's odd about this bug (at least to me, I'm not a programmer) is that it only ever happened to me on Frozen City. No other maps seemed to have been affected. Or maybe Frozen City is the only one where it is noticeable? *shrug*




S.

#8 The Flaming Git

    Member

  • Veteran Founder
  • 43 posts

Posted 07 February 2014 - 07:31 AM

You… you…. you BEAUTIFUL person you! Thank you thank you thank you. This was driving me crazy!

#9 scgt1

    Member

  • Legendary Founder
  • The Defiant
  • The Defiant
  • 198 posts
  • Facebook: Link
  • LocationArlington, TX

Posted 07 February 2014 - 07:37 AM

lol I've never had the issue :-D

#10 Bazooka B

    Member

  • Members
  • Pip
  • 11 posts

Posted 07 February 2014 - 08:19 AM

View PostAlbert Meyburgh, on 06 February 2014 - 02:40 PM, said:

vsync makes the shaders rebuild so it's probably related to a bug we've been tracking regarding the game getting corrupt during async shader compilation. we're possibly turning off async shader compile when dx11 is released but it's not my dept so I'm not sure. In the meanwhile if you delete your user shader cache, run the repair tool, and add r_ShadersAsyncCompiling=0 to your user.cfg it MAY resolve the issue but no promises for now :angry:



Vsnyc also causes my game to max my FPS at 60. Before the Feb 4th patch I was getting 120fps - 70fps, since this patch I get 90fps - 30fps, but with vsync turned on the low end sometimes drops below 10fps. This is not OK and your recommendations are not an acceptable solution.

These frame rates are ludicrous considering what I was getting before the patch and considering the hardware I have.
i5 4670k OC to 4.0GHz
GeForce GTX 760
16 GB PC12800

Edited by Bazooka B, 07 February 2014 - 08:20 AM.


#11 DragonsFire

    Member

  • Legendary Founder
  • The Ironclad
  • The Ironclad
  • 652 posts

Posted 07 February 2014 - 08:24 AM

View PostBazooka B, on 07 February 2014 - 08:19 AM, said:



Vsnyc also causes my game to max my FPS at 60. Before the Feb 4th patch I was getting 120fps - 70fps, since this patch I get 90fps - 30fps, but with vsync turned on the low end sometimes drops below 10fps. This is not OK and your recommendations are not an acceptable solution.

These frame rates are ludicrous considering what I was getting before the patch and considering the hardware I have.
i5 4670k OC to 4.0GHz
GeForce GTX 760
16 GB PC12800


You may need to reset your video graphics preset as there was an issue with this patch in how it's currently functioning. Further information on that can be found here:
http://mwomercs.com/...ost__p__3127361

You may also need to make changes to Windowed Mode (Full Window vs Fullscreen).

#12 Shamous13

    Member

  • Legendary Founder
  • 661 posts
  • LocationKitchener, Ont.

Posted 07 February 2014 - 08:28 AM

View PostBazooka B, on 07 February 2014 - 08:19 AM, said:



Vsnyc also causes my game to max my FPS at 60. Before the Feb 4th patch I was getting 120fps - 70fps, since this patch I get 90fps - 30fps, but with vsync turned on the low end sometimes drops below 10fps. This is not OK and your recommendations are not an acceptable solution.

These frame rates are ludicrous considering what I was getting before the patch and considering the hardware I have.
i5 4670k OC to 4.0GHz
GeForce GTX 760
16 GB PC12800


Vsync will match the max fps to the max refresh rate of the screen you are using that's probably why your seeing a max of 60.

I've noticed a trend with the fps complaints and soft locks. it seems to be more people with NVIDIA cards having issues. have you updated to the latest drivers? http://www.nvidia.ca...aspx?lang=en-us

also note Some people have reported their user config not working and it is believed (not confirmed yet) the game looks for "prohibited" settings, and just disables the whole cfg if it finds any. here's a quote from another person that tested this hypothesis.

View PostMnDragon, on 07 February 2014 - 07:16 AM, said:

the Omicron.txt file seems to be dump log for each session you load and basically goes through everything you do. Each map you play, everytime you go to the mechlab etc. It was where I found the "cl_joystick_* unrecognized command" BS that led me to believe the user.cfg was no longer working. Based on your statement above, I did some experimentation and dropped everything but the cl_fov= line. I didn't get the warning line as I had before when I had the joystick lines in the .cfg. So I would venture to say that this is an accurate statement. If you adjust your user.cfg to only incorporate lines that are still used by the game, (obviously the joystick lines are no longer needed, the UI does the same thing) it should work.

Edited by Shamous13, 07 February 2014 - 08:33 AM.


#13 Albert Meyburgh

    Systems Engineer

  • Staff
  • 74 posts
  • Location404

Posted 07 February 2014 - 09:47 AM

View PostBazooka B, on 07 February 2014 - 08:19 AM, said:



Vsnyc also causes my game to max my FPS at 60. Before the Feb 4th patch I was getting 120fps - 70fps, since this patch I get 90fps - 30fps, but with vsync turned on the low end sometimes drops below 10fps. This is not OK and your recommendations are not an acceptable solution.

These frame rates are ludicrous considering what I was getting before the patch and considering the hardware I have.
i5 4670k OC to 4.0GHz
GeForce GTX 760
16 GB PC12800


sorry I should clarify, if you follow these steps as I suggested, you can turn vsync off again, and since async compiling is disabled with that user.cfg flag, the corruption would thus be avoided in the future... so it is a permanent workaround in theory with no need to rely on vsync to force a rebuild... but no warranty as I said :P I am just throwing it out there since I can appreciate the frustration.

#14 Deucebackpack

    Member

  • Members
  • PipPip
  • 36 posts

Posted 10 February 2014 - 12:19 PM

Yes indeed enabling V-Sync in the options solved this missing texture problem for me. However it did slow down my game which was a problem for me since my computer is low end.

The suggestion about editing user.cfg sounds interesting and I should try it sometime.

By the way deleting the shaders folder or even re-installing the game had no effect for me.

Since this is an issue that is bothering many players of MWO would'nt it be a good idea to post these fix suggestions in a sticky thread somewhere? Perhaps in the Frequently Asked Questions area?


EDITED:
Theres another thread here http://mwomercs.com/...r-texture-bugs/
that discusses this same issue. just wanted to add the link in this post so the information is easy to find.

Quote

The user.cfg edit did not work for me. Still had missing textrures on frozen city. Only fix that works 100% for me is turning on V-Sync in the options.

Also an interesting thing is that if I play singleplayer in the testing grounds i never have the missing textures. It only happens while playing online. So might even be related to some net code issues but that is just an uneducated guess on my part.

Anyways turning V-Sync on works for me so I'm fine.

Edited by Deucebackpack, 11 February 2014 - 07:50 AM.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users