Jump to content

Mw5: Thrustmaster T-16000M 'throttle Bug' Work-Around


22 replies to this topic

#1 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 13 December 2019 - 10:23 AM

So this will get your Thrustmaster T-16000m throttle working in MW5. Go to your Saved HOTAS folder in AppData\Local\MW5Mercs\Saved\SavedHOTAS and add this line to HOTASMapping.remap file at the bottom of the T-16000-m section:

AXIS: InAxis=GenericUSBController_Axis4, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE

When you are done it should look like this:

START_BIND
NAME: THRUSTMASTER TWCS Throttle
VID: 0x044F
PID: 0xB687
BUTTON: InButton=GenericUSBController_Button1, OutButtons=Throttle_Button1
BUTTON: InButton=GenericUSBController_Button2, OutButtons=Throttle_Button2
BUTTON: InButton=GenericUSBController_Button3, OutButtons=Throttle_Button3
BUTTON: InButton=GenericUSBController_Button4, OutButtons=Throttle_Button4
BUTTON: InButton=GenericUSBController_Button5, OutButtons=Throttle_Button5
BUTTON: InButton=GenericUSBController_Button6, OutButtons=Throttle_Button6
BUTTON: InButton=GenericUSBController_Button7, OutButtons=Throttle_DPad1_Up
BUTTON: InButton=GenericUSBController_Button8, OutButtons=Throttle_DPad1_Right
BUTTON: InButton=GenericUSBController_Button9, OutButtons=Throttle_DPad1_Down
BUTTON: InButton=GenericUSBController_Button10, OutButtons=Throttle_DPad1_Left
BUTTON: InButton=GenericUSBController_Button11, OutButtons=Throttle_DPad2_Up
BUTTON: InButton=GenericUSBController_Button12, OutButtons=Throttle_DPad2_Right
BUTTON: InButton=GenericUSBController_Button13, OutButtons=Throttle_DPad2_Down
BUTTON: InButton=GenericUSBController_Button14, OutButtons=Throttle_DPad2_Left
BUTTON: InButton=GenericUSBController_Hat1, OutButtons=Throttle_Hat_1
BUTTON: InButton=GenericUSBController_Hat2, OutButtons=Throttle_Hat_2
BUTTON: InButton=GenericUSBController_Hat3, OutButtons=Throttle_Hat_3
BUTTON: InButton=GenericUSBController_Hat4, OutButtons=Throttle_Hat_4
BUTTON: InButton=GenericUSBController_Hat5, OutButtons=Throttle_Hat_5
BUTTON: InButton=GenericUSBController_Hat6, OutButtons=Throttle_Hat_6
BUTTON: InButton=GenericUSBController_Hat7, OutButtons=Throttle_Hat_7
BUTTON: InButton=GenericUSBController_Hat8, OutButtons=Throttle_Hat_8
AXIS: InAxis=HOTAS_ZAxis, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis2, Invert=FALSE, Offset=-0.498039, DeadZoneMin=-0.1, DeadZoneMax=0.1, MapToDeadZone=FALSE
 
 
START_BIND
NAME: THRUSTMASTER T.16000M Joystick
VID: 0x044F
PID: 0xB10A
BUTTON: InButton=GenericUSBController_Button1, OutButtons=Joystick_Button1
BUTTON: InButton=GenericUSBController_Button2, OutButtons=Joystick_Button2
BUTTON: InButton=GenericUSBController_Button3, OutButtons=Joystick_Button3
BUTTON: InButton=GenericUSBController_Button4, OutButtons=Joystick_Button4
BUTTON: InButton=GenericUSBController_Button5, OutButtons=Joystick_Button5
BUTTON: InButton=GenericUSBController_Button6, OutButtons=Joystick_Button6
BUTTON: InButton=GenericUSBController_Button7, OutButtons=Joystick_Button7
BUTTON: InButton=GenericUSBController_Button8, OutButtons=Joystick_Button8
BUTTON: InButton=GenericUSBController_Button9, OutButtons=Joystick_Button9
BUTTON: InButton=GenericUSBController_Button10, OutButtons=Joystick_Button10
BUTTON: InButton=GenericUSBController_Button11, OutButtons=Joystick_Button11
BUTTON: InButton=GenericUSBController_Button12, OutButtons=Joystick_Button12
BUTTON: InButton=GenericUSBController_Button13, OutButtons=Joystick_Button13
BUTTON: InButton=GenericUSBController_Button14, OutButtons=Joystick_Button14
BUTTON: InButton=GenericUSBController_Button15, OutButtons=Joystick_Button15
BUTTON: InButton=GenericUSBController_Button16, OutButtons=Joystick_Button16
BUTTON: InButton=GenericUSBController_Hat1, OutButtons=Joystick_Hat_1
BUTTON: InButton=GenericUSBController_Hat2, OutButtons=Joystick_Hat_2
BUTTON: InButton=GenericUSBController_Hat3, OutButtons=Joystick_Hat_3
BUTTON: InButton=GenericUSBController_Hat4, OutButtons=Joystick_Hat_4
BUTTON: InButton=GenericUSBController_Hat5, OutButtons=Joystick_Hat_5
BUTTON: InButton=GenericUSBController_Hat6, OutButtons=Joystick_Hat_6
BUTTON: InButton=GenericUSBController_Hat7, OutButtons=Joystick_Hat_7
BUTTON: InButton=GenericUSBController_Hat8, OutButtons=Joystick_Hat_8
AXIS: InAxis=HOTAS_XAxis, OutAxis=Joystick_Axis2, Invert=FALSE, Offset=-0.498039, DeadZoneMin=-0.1, DeadZoneMax=0.1, MapToDeadZone=FALSE
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis3, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.2, DeadZoneMax=0.2, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_YAxis, OutAxis=Joystick_Axis1, Invert=FALSE, Offset=-0.498039, DeadZoneMin=-0.3, DeadZoneMax=0.3, MapToDeadZone=TRUE
AXIS: InAxis=GenericUSBController_Axis4, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE


The line you have added is at the very bottom. Then select "Throttle Axis 1" in the Options/Controllers/Joystick tab. Notepad++ makes the file easier to read. It also preserves the file format. My thanks to Kvetcha on Discord for the tip to test!

Good Luck & Happy Hunting! Posted Image

Edited by Lightfoot, 13 December 2019 - 09:25 PM.


#2 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 10:57 AM

View PostLightfoot, on 13 December 2019 - 10:23 AM, said:

So this will get your Thrustmaster T-16000m throttle working in MW5. Go to your Saved HOTAS folder in AppData\Local\MW5Mercs\Saved\SavedHOTAS and add this line to HOTASMapping.remap file at the bottom of the T-16000-m section:

AXIS: InAxis=GenericUSBController_Axis4, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE



Thank you! Now alll my axes and throttle work.

None of the buttons work. I'm still fighting that, but at least the throttle works. One problem at a time :)

#3 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 13 December 2019 - 11:04 AM

View PostEurystheus, on 13 December 2019 - 10:57 AM, said:

Thank you! Now alll my axes and throttle work.

None of the buttons work. I'm still fighting that, but at least the throttle works. One problem at a time Posted Image


They work fine for me. I am using the newer 2.FFD.2018 joystick drivers, but it also worked with the 2017 drivers. I just went to the MW5/Options/Joystick tab and entered the joystick button presses I wanted to assign to the commands.

#4 Haiiro Neko

    Rookie

  • The Vicious
  • The Vicious
  • 7 posts

Posted 13 December 2019 - 11:15 AM

OMG, Thank you!!
I was about to give up on the game but this actually works!
Now I can finally start to play the game Posted Image

#5 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 11:31 AM

View PostLightfoot, on 13 December 2019 - 11:04 AM, said:

They work fine for me. I am using the newer 2.FFD.2018 joystick drivers, but it also worked with the 2017 drivers. I just went to the MW5/Options/Joystick tab and entered the joystick button presses I wanted to assign to the commands.


I did install the 2018 driver. When I attempt to change the or assign the joystick buttons in options it ignores the command. For example, Fire Weapon Group 1 is assigned to Joystick Button 1. With an x next to the box. If I click inside the box it changes from Joystick Button 1 to Press any key. No matter which key I press, on the joystick or the keyboard, it comes back as Joystick Button 1.

If I clear the X, it changes from Joystick Button 1 to NONE. If I click inside the box it changes from NONE to Press any key. When I press a key it goes back to NONE.

#6 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 13 December 2019 - 12:24 PM

What about the other buttons? The trigger may be hardwired for some reason.

#7 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 01:15 PM

I'm pretty sure now that I am unable to override the button default assignments. I recoded buttons 1 - 9them to this:

BUTTON: InButton=GenericUSBController_Button1, OutButtons=Joystick_Button9
BUTTON: InButton=GenericUSBController_Button2, OutButtons=Joystick_Button8
BUTTON: InButton=GenericUSBController_Button3, OutButtons=Joystick_Button7
BUTTON: InButton=GenericUSBController_Button4, OutButtons=Joystick_Button6
BUTTON: InButton=GenericUSBController_Button5, OutButtons=Joystick_Button5
BUTTON: InButton=GenericUSBController_Button6, OutButtons=Joystick_Button4
BUTTON: InButton=GenericUSBController_Button7, OutButtons=Joystick_Button3
BUTTON: InButton=GenericUSBController_Button8, OutButtons=Joystick_Button2
BUTTON: InButton=GenericUSBController_Button9, OutButtons=Joystick_Button1

And it made no difference in my options. Fire Weapon Group 1, which I assumed should now be assigned to button 9 is still assigned to button 1.

None of the buttons work, either under the default mapping found in the .Remap file, nor when I try to change them in the options. It is like there is a default that I cannot override.

#8 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 01:19 PM

Oh, if I try to make changes in the options for mouse/keyboard, those changes work fine. No difficulties at all. At one point I thought the .Remap file was being ignored altogether, but the throttle mapping suggestion you made worked just fine. So it must be reading the file.

I thought I might have a syntax error somewhere, or an unreadable character that was fouling things up, so I renamed the .Remap file, restarted the game, got a new remap file, and had the same problems.

#9 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 13 December 2019 - 02:41 PM

Maybe you can manually edit the GameUserSetting.ini -in AppData\Local\MW5Mercs\Saved\Config\WindowsNoEditor. Also if you installed MW5 to C:\Program Files (x86) or C:\Program Files, try running the game in Admin mode since edits to files in these folders sometimes require admin privileges. I installed to drive E which is not blocked. .ini files are just text files usually and open with notepad.


... I see we just got a patch too!

Edited by Lightfoot, 13 December 2019 - 02:44 PM.


#10 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 03:34 PM

Okay, so I found in the GameUserSetting.ini file the line where the joystick buttons are defined. I changed them to map button 1 to 1, button 2 to 2, etc. and that worked. In the .ini file they were assigned out of order, so, for example, joystick button 2 was assigned to button 4.

I was also able to add joystick buttons 5 and 6.

Saved it, started up the game, and the key mappings matched the changes I made. Yay! But, sad to say, the buttons still don't work in the game.

#11 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 03:49 PM

This is interesting. In the .ini file I changed the buttons, so Fire Weapon Group 2, which was assigned to Joystick button 3, is now assigned to Joystick Button 2. When I start the game, that is what I see. BUT, if I click on DEFAULTS, the assignment goes back to Joystick Button 3. So the defaults are stored somewhere else ...

#12 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 13 December 2019 - 05:11 PM

Strange. The GameUserSetting.ini file updates with any changes I make in the MW5 Joystick tab. The only thing I might have done different from others is to install to a directory on Drive E: instead of the default on C: And i am using Windows 7 64 pro which might be different too. Oh, and I didn't install to the same path as the MW5Beta folder. Not sure if any of that might have made a difference though. Ask around on the Discord channel.

#13 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 05:30 PM

I uninstalled the Beta. I have seen .Remap configs on the Discord that look exactly like mine. Thinking I will uninstall the game then go hunting for any directories that were left over, then delete those and reinstall.

#14 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 06:00 PM

This is absolutely amazing!

I uninstalled the game and discovered that the ApData/Local/MW5Mercs directory was still there, and populated. So I deleted that directory and reinstalled the game.

Then I ran the game without making any changes (didn't add the throttle axis line you gave me earlier) and lo and behold, the buttons worked, and I could redefine them to my hearts content. Didn't have the throttle, but all I had to do was add that one line back to the .Remap file.

Then I restarted the game, and had all the axes working ... and none of the buttons. Adding that one little line to the .Remap file killed the buttons. And I can't remap them from the game.

Arrgh!!!!!!!

#15 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 06:25 PM

Okay. Finally. I was grasping at straws. I thought, maybe, the editor I was using was screwing things up. On my new machine I never reinstalled Notepad++, so I was using Wordpad to edit the files. I switched to Notepad, and everything is working now.

Thank you so much for your help!

#16 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 13 December 2019 - 09:23 PM

yw, Glad you got it working for you. Yes, always use Notepad++ or some editor like it to edit code, just to be sure.

#17 Eurystheus

    Member

  • PipPipPip
  • The Grizzly
  • The Grizzly
  • 86 posts

Posted 13 December 2019 - 10:01 PM

View PostLightfoot, on 13 December 2019 - 09:23 PM, said:

yw, Glad you got it working for you. Yes, always use Notepad++ or some editor like it to edit code, just to be sure.


I can remember a few years back (maybe more than a few) when my son introduced me to Notepad++. I installed it and was instant messaging with him, and I said, "It even supports COBOL!" And he said, "What's COBOL?" And I replied, "LOL! I guess we've come a long ways from the green screen days." And he said, "What's a green screen?"

I've been in I/T for a long time. I tell people that when I started we coded right down on the bare metal. I once coded an entire database management system in zeros, because ones hadn't been invented yet.

In my last job I was still able to do some IBM zSystems BAL coding. Fun stuff, but not as fun as playing Mechwarrior!

#18 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 14 December 2019 - 09:09 AM

My first look at a computer was a mainframe. First game was a Star Trek game where space was a 10x10 type face grid with 3 numbers in each grid representing stars, star bases, and Klingons in the system. Immensely popular game, consumed so many cycles they created a password exclusion. We were just testing the photon torpedoes and fired two off in opposite directions. Game responded with, "Firing photon torpedoes in a star system with no Klingons is an act of insanity. Mr. Spock has relieved you of command on those grounds. Game Over." So hilarious.

#19 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 14 December 2019 - 09:32 AM

linked op in my joystick thread.

#20 Lightfoot

    Member

  • PipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 6,558 posts
  • LocationOlympus Mons

Posted 15 December 2019 - 02:33 PM

Thanks. A lot of people have had this problem.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users