Jump to content

Mw5 Joystick Workarounds Thread


111 replies to this topic

#61 Joaostorfe

    Rookie

  • The Hunter
  • The Hunter
  • 5 posts

Posted 13 December 2019 - 08:34 AM

View PostLordNothing, on 12 December 2019 - 06:19 PM, said:


maybe. i use my ch pedals but yours should work. problem is its hard to make a profile for somone without having the device on hand to test.


Maybe i can help =P. What kind of data you need?

#62 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 13 December 2019 - 05:41 PM

View PostJoaostorfe, on 13 December 2019 - 08:34 AM, said:


Maybe i can help =P. What kind of data you need?


vid/pid numbers for the stick (pedals) would be a good place to start. pgi's manual was pretty good with this regard, but i find its a lot easier to use run->dxdiag and then click on the input tab, find your pedals in the list. post the vendor id and product id of that stick.

then go into run->joy.cpl, double click on your pedals and post a screen cap of the list of axes. should help me id what to assign to what.

that goes for everyone with a controller that they cant make work.

Edited by LordNothing, 13 December 2019 - 05:46 PM.


#63 Joaostorfe

    Rookie

  • The Hunter
  • The Hunter
  • 5 posts

Posted 14 December 2019 - 02:51 AM

View PostLordNothing, on 13 December 2019 - 05:41 PM, said:


vid/pid numbers for the stick (pedals) would be a good place to start. pgi's manual was pretty good with this regard, but i find its a lot easier to use run->dxdiag and then click on the input tab, find your pedals in the list. post the vendor id and product id of that stick.

then go into run->joy.cpl, double click on your pedals and post a screen cap of the list of axes. should help me id what to assign to what.

that goes for everyone with a controller that they cant make work.


https://imghostr.com/F2NajyZKy

Update:
I managed to make it work, the process is quite simple. I just added the following lines below:

START_BIND
NAME: G27 Wheel Joystick
VID: 0x046D
PID: 0xC29B
AXIS: InAxis = HOTAS_YAxis, OutAxis = Joystick_Axis5, Invert = True, Offset = -0.498039, DeadZoneMin = -0.05, DeadZoneMax = 0.08, MapToDeadZone = TRUE

Edited by Joaostorfe, 14 December 2019 - 03:34 AM.


#64 Oraeon1224

    Member

  • PipPipPip
  • 53 posts

Posted 14 December 2019 - 08:49 AM

I have my thrustmaster warthog HOTAS working in MW5. However, I can't get my thrustmaster rudder pedals to work. This is unfortunate since that is how I steer in MWO. Currently when I try to us it the Mech starts turning left and won't stop. Any idea why his edit doesn't work?


START_BIND
NAME: THRUSTMASTER RUDDER Pedals
VID: 0x044F
PID: 0xB679
AXIS: InAxis=HOTAS_ZAxis, OutAxis=Throttle_Axis3, Invert=FALSE, Offset=-0.9, DeadZoneMin=-0.3, DeadZoneMax=0.3, MapToDeadZone=FALSE

#65 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 14 December 2019 - 08:58 AM

ok i think im going to clean up the op a bit, probibly just move all the legacy stuff to another post, put links to posts of known working profiles in there as well so as to help others. legacy stuff:

all this stuff below here is old beta stuff
it might still be useful but dont rely on it
---------------------------------------------------------------------------

if pgi needed a reason why mw5 needed its own forum, here it is.

anyway despite the fact that joysticks were supposedly supported by the game, i have found that there is zero support for directinput sticks, which is what most of the fancy hotas units use because xinput only supports 6 axes and 10 buttons (my joystick has 40 buttons and 9 axes). why microsoft chose to replace a really good api for a less capable one is beyond me (it probably has something to do with trying to sell xbox controllers by screwing over the competition). this has been the bane of hotas users for at least a decade now.

so far the way to get this to work is with a xinput wrapper. there are a lot of these on the internet. but so far i have had some luck with XOutput. while all my buttons are taken care of in the ch software (all bound to the default keys and acting as a keyboard), i still had the problem with axes. XOutput let me map the ch axes to xinput axes allowing me to use my stick.

i want to try some other work arounds as this one has a deadzone the size of texas (this is probably a game settings issue as all my deadzone settings are zero, i currently have not figured out where the config files are stored), but so far this is the one that works. il post other solutions here as ive tested them.

now featuring instructions. sorry, they aren't very good.

View PostLordNothing, on 27 November 2019 - 05:27 PM, said:

xoutput remains the only thing that has worked so far. to get it to work, first grab xoutput from here

https://github.com/c...Output/releases

installation instructions are here

https://github.com/csutorasa/XOutput

it gives a list of dependencies but i only had to instal the VGIEm framework and xbox360 controller drivers to get it to work. i may have already had the visual c++ redistributables installed already (im a programmer) so you might want to install those too. im still looking for a single installer solution.

extract xoutput to a folder somewhere (doesnt really matter where) and run it. at the top of the window are a list of direct input controllers. make sure your stick is recognized. it will highlight green when you interact with it. under game controllers click add controller, and then edit. you can then configure your mappings. the panel on the right represents the controller functions the game will see. just close it when you are happy with your mappings. you can then save the configuration. click start to activate the virtual controller. after that you can minimize it and run mw5. your controls should work.


click here for picture instructions on configuring xoutput. (i was gonna hotlink it here but since there are no spoiler tags i thought it would take up too much space).

troubleshooting:

View PostLordNothing, on 29 November 2019 - 06:01 PM, said:


XOutput has some dependencies. and those dependancies have their own dependencies. i was able to get it to run just by installing VIGEm and the xbox 360 controller drivers. thats all i had to install to get it to work.

are you on windows 10? if not i think you have to install some dotnet stuff.

also try the vc++ redistributables.


View PostLordNothing, on 30 November 2019 - 03:51 PM, said:

are you leaving the XOutput running when you start the game? because it will stop emulating the gamepad when you close it.

to test if its working hit windows+r and type in "joy.cpl" to bring up the joystick control panel. when you run xoutput and start the controller, a new device will show up in the panel. you can test the bindings by hitting properties. if none of those are working then stop the controller and edit your bindings in xoutput.


heres an alternative for the Logitech Extreme 3d pro.

View PostSurn, on 01 December 2019 - 09:29 PM, said:

https://github.com/O...-Configurations

Here is my input.ini for Logitech Extreme 3d pro and have some test files with more joysticks

Edited by LordNothing, 14 December 2019 - 08:59 AM.


#66 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 14 December 2019 - 09:04 AM

View PostOraeon1224, on 14 December 2019 - 08:49 AM, said:

I have my thrustmaster warthog HOTAS working in MW5. However, I can't get my thrustmaster rudder pedals to work. This is unfortunate since that is how I steer in MWO. Currently when I try to us it the Mech starts turning left and won't stop. Any idea why his edit doesn't work?


START_BIND
NAME: THRUSTMASTER RUDDER Pedals
VID: 0x044F
PID: 0xB679
AXIS: InAxis=HOTAS_ZAxis, OutAxis=Throttle_Axis3, Invert=FALSE, Offset=-0.9, DeadZoneMin=-0.3, DeadZoneMax=0.3, MapToDeadZone=FALSE


is this not working at all or is it being erratic? these settings look all wrong. the -0.9 offset would put the center way off to one side, and the deadzone would overlap that side too (you would only be able to turn in one direction). i also notice you are using the z axis and mapping it to throttle 3, which is odd for pedals. mine looks like this

AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis3, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE


of course you might be using a different in axis. try getting the axis list in run->joy.cpl, it might be something other than z.

Edited by LordNothing, 14 December 2019 - 09:22 AM.


#67 Oraeon1224

    Member

  • PipPipPip
  • 53 posts

Posted 14 December 2019 - 07:15 PM

Thank you so much for the help LordNothing it now works. The deadzone was the screw up it is ZAxis for my particular controller. I rewrote the section to read

START_BIND
NAME:THRUSTMASTER RUDDER PEDALS
VID: 0x044F
PID: 0xB679

AXIS: InAxis = HOTAS_ZAxis, Outaxis = Joystick_Axis3, Invert =Fale, Offset =-0.5, DeadZoneMin =-0.08, DeadZoneMax = 0.08, MapToDeadZone = True

Anyone else who wants to use rudders should try the above n substitute in the VID and PID for your product. I only edited the REMAP file and didn't need any additional software to get by Thrust-master Warthog Joystick, Throttle, or Rudder to work.

#68 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 15 December 2019 - 08:33 AM

View PostOraeon1224, on 14 December 2019 - 07:15 PM, said:

Thank you so much for the help LordNothing it now works. The deadzone was the screw up it is ZAxis for my particular controller. I rewrote the section to read

START_BIND
NAME:THRUSTMASTER RUDDER PEDALS
VID: 0x044F
PID: 0xB679

AXIS: InAxis = HOTAS_ZAxis, Outaxis = Joystick_Axis3, Invert =Fale, Offset =-0.5, DeadZoneMin =-0.08, DeadZoneMax = 0.08, MapToDeadZone = True

Anyone else who wants to use rudders should try the above n substitute in the VID and PID for your product. I only edited the REMAP file and didn't need any additional software to get by Thrust-master Warthog Joystick, Throttle, or Rudder to work.


ok i will add it to the list.

#69 GODzillaGSPB

    Member

  • PipPipPipPipPipPipPipPipPip
  • 2,028 posts
  • LocationGermany

Posted 15 December 2019 - 02:04 PM

I'm really close refunding the game over the fact that the analog throttle switch at the front of my Thrustmaster TWCS Throttle was working for 10 minutes when I tried it in an Instant Action map, but then went out of comission during the tutorial. I'm currently reinstalling the game as a last ditch effort and if that doesn't help --> refund. It's embarassing! This was working perfectly fine in MWO and I played the beta back then.

I did confirm that the axis is working perfectly fine within the driver / controller setup and it is also working perfectly fine in Rebel Galaxy Outlaw. But somehow MW5 f**ked it up! -.-

#70 Steve Jenner Hobba

    Member

  • Pip
  • Bad Company
  • Bad Company
  • 16 posts

Posted 17 December 2019 - 12:37 AM

View PostLordNothing, on 10 December 2019 - 07:43 PM, said:

now you have to edit HOTASMappings.remap.

working profile for my ch throttle,pedals, and fighterstick:
START_BIND
NAME: CH Control Manager Device 1
VID: 0x068E
PID: 0xC010
AXIS: InAxis=HOTAS_XAxis, OutAxis=Joystick_Axis1, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_YAxis, OutAxis=Joystick_Axis2, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_ZAxis, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.10, DeadZoneMax=0.10, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis3, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE

requires the sticks be combined in ch control manager. maps to x,y,z,and r axes. i also mapped the buttons directly to the keystrokes for the default keyboard commands, which saves a lot of steps.

important stuff is the name, pid and vid numbers, which can be obtained from either the device manager or the input tab of dxdiag. dont forget the 0x prefix because it is hex. my axis configuration assumes a standard 4-axis controller (x,y,z,r). the out axis is the one you map in game, the in axis idk where it gets those names from, it took some trial and error. i also noticed that if you use invert=true, then offset needs to be positive, weird stuff happens if you don't do that. deadzone min and max should be the same with the min negative. i assume that 0.1 is 10 percent, which is a bit high, 0.02 worked for my stick, i like a broader dead zone in the throttle to make it easier to stop, and the pedals have a huge fuzzy center so i gave it a full 0.1. i still haven't figured out what map to deadzone does yet, so i turned it off. if you want buttons just copy the button lines from one of the other examples and stick it between pid and axis. one line for each button, and increment the numbers. i got it to work without messing with input.ini (which i cleared).

its not perfect but it is working with more sticks and virtual drivers.


This i great news, Thanks for digging that nugget up. I will give it a try today.

You don't happen to have the .cmc file at hand for the command list? Got a Combatstick on the and the pro pedals under the table but had not figured out the mapping of the games default keys to buttons/hats.

I'd really appreciate the cmc file. Thanks a lot in advance!

#71 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 17 December 2019 - 11:31 AM

View PostSteve Jenner Hobba, on 17 December 2019 - 12:37 AM, said:


This i great news, Thanks for digging that nugget up. I will give it a try today.

You don't happen to have the .cmc file at hand for the command list? Got a Combatstick on the and the pro pedals under the table but had not figured out the mapping of the games default keys to buttons/hats.

I'd really appreciate the cmc file. Thanks a lot in advance!


here's my ch map. its the one i use with my controllers. most of the controls are on the throttle side so it works pretty well with a mouse, the stick side controls are very rudimentary at best (pretty much weapons, zoom controls, and lance commands). i know there are a couple mappings that are wrong, i made this profile for the demo so some bindings are bad because they moved a couple keys.

ultimately it really doesnt matter how you set it up or what sticks you are using. just make sure it outputs on cm device one, axes x,y,z,r. and map the buttons directly to keyboard commands. its a lot easier than mapping it in the game.

#72 Steve Jenner Hobba

    Member

  • Pip
  • Bad Company
  • Bad Company
  • 16 posts

Posted 17 December 2019 - 12:02 PM

Again you made my day for my Combatstick pedal combo!

In the meantime i can give testimony that my axes somehow all worked
after some shuffling them from one to another in the in game alignments. However binding ingame buttons gave me missing buttons so this map file might save the day again.

Thanks a lot for the investigative work to figure out some solutions.

#73 Mystere

    Member

  • PipPipPipPipPipPipPipPipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 22,783 posts
  • LocationClassified

Posted 18 December 2019 - 10:43 AM

Just checking in to ask ...

Has there been any patch that includes major improvements in stick support?

Does anyone have a Thrustmaster Warthog + T.Flight pedal setup fully working, preferably via TARGET?

I've been sacking cities in TW:R2 in the meantime. Posted Image

Edited by Mystere, 18 December 2019 - 10:44 AM.


#74 RangerMNDN

    Member

  • Pip
  • The Ironclad
  • The Ironclad
  • 19 posts

Posted 18 December 2019 - 03:04 PM

I was playing a mission in MW5 with rudder pedals for steering all working fine. Finished the mission and closed down the game. Came back and went to play the next mission the rudder pedals are no longer working.Here is the Rudder pedals line in the HOTASMappings.remap is
NAME:PROFLIGHT RUDDER PEDALS
VID: 0x06A3
PID: 0x0763
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis5, Invert=FALSE, Offset=-0.498039, DeadZoneMin=-0.1, DeadZoneMax=0.1, MapToDeadZone=FALSE

any help would be appreciated thank you

#75 Warhawke_

    Member

  • Pip
  • Survivor
  • 18 posts
  • LocationThe Great State of Texas

Posted 18 December 2019 - 07:19 PM

Was wondering if anyone has had luck with the Saitek Pro Flight X-55 Rhino?




#76 Peace2U

    Member

  • PipPipPipPipPipPip
  • 319 posts

Posted 19 December 2019 - 09:32 AM

Been watching this post for a while now because joystick control is my preferred play style.
I have been waiting to purchase for PGI/Unreal4 to provide decent joystick functionality in-game vs having to run 3rd party utilities to force a conventional USB stick to be accepted.

Does anyone here use the Microsoft Sidewinder 3D Force Feedback stick?
VID 0x045E
PID 0x001B
And have you had any luck with getting it to work using Start_Bind configuration?

I'm looking forward to playing this game but don't want to buy a pig-in-a-poke if it does not properly support analog sticks.

Thanks Mechwarriors.
Peace

#77 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 19 December 2019 - 12:22 PM

View PostPeace2U, on 19 December 2019 - 09:32 AM, said:

Been watching this post for a while now because joystick control is my preferred play style.
I have been waiting to purchase for PGI/Unreal4 to provide decent joystick functionality in-game vs having to run 3rd party utilities to force a conventional USB stick to be accepted.

Does anyone here use the Microsoft Sidewinder 3D Force Feedback stick?
VID 0x045E
PID 0x001B
And have you had any luck with getting it to work using Start_Bind configuration?

I'm looking forward to playing this game but don't want to buy a pig-in-a-poke if it does not properly support analog sticks.

Thanks Mechwarriors.
Peace


i cant really test it but i used to own at some point the old style gameport ff joystick. assuiming it has the same button layout as i remember.

START_BIND
NAME: Microsoft Sidewinder 3D Force Feedback
VID: 0x045E
PID: 0x001B
BUTTON: InButton=GenericUSBController_Button1, OutButtons=Joystick_Button1
BUTTON: InButton=GenericUSBController_Button2, OutButtons=Joystick_Button2
BUTTON: InButton=GenericUSBController_Button3, OutButtons=Joystick_Button3
BUTTON: InButton=GenericUSBController_Button4, OutButtons=Joystick_Button4
BUTTON: InButton=GenericUSBController_Button5, OutButtons=Joystick_Button5
BUTTON: InButton=GenericUSBController_Button6, OutButtons=Joystick_Button6
BUTTON: InButton=GenericUSBController_Button7, OutButtons=Joystick_Button7
BUTTON: InButton=GenericUSBController_Button8, OutButtons=Joystick_Button8
BUTTON: InButton=GenericUSBController_Hat1, OutButtons=Joystick_Hat_1
BUTTON: InButton=GenericUSBController_Hat2, OutButtons=Joystick_Hat_2
BUTTON: InButton=GenericUSBController_Hat3, OutButtons=Joystick_Hat_3
BUTTON: InButton=GenericUSBController_Hat4, OutButtons=Joystick_Hat_4
BUTTON: InButton=GenericUSBController_Hat5, OutButtons=Joystick_Hat_5
BUTTON: InButton=GenericUSBController_Hat6, OutButtons=Joystick_Hat_6
BUTTON: InButton=GenericUSBController_Hat7, OutButtons=Joystick_Hat_7
BUTTON: InButton=GenericUSBController_Hat8, OutButtons=Joystick_Hat_8
AXIS: InAxis=HOTAS_XAxis, OutAxis=Joystick_Axis1, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_YAxis, OutAxis=Joystick_Axis2, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_ZAxis, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.10, DeadZoneMax=0.10, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis3, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE


let me know if it works and i will add it to the list of known working configs.

View PostRangerMNDN, on 18 December 2019 - 03:04 PM, said:

I was playing a mission in MW5 with rudder pedals for steering all working fine. Finished the mission and closed down the game. Came back and went to play the next mission the rudder pedals are no longer working.Here is the Rudder pedals line in the HOTASMappings.remap is
NAME:PROFLIGHT RUDDER PEDALS
VID: 0x06A3
PID: 0x0763
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis5, Invert=FALSE, Offset=-0.498039, DeadZoneMin=-0.1, DeadZoneMax=0.1, MapToDeadZone=FALSE

any help would be appreciated thank you


i had thiss problem too. after changing a control that was moved or rebound after the patch, my rudder stopped working. i had to go into the joystick tab and up the sensitivity, somehow it got reset to zero. if that fixes it i can add it to the list.

Edited by LordNothing, 19 December 2019 - 12:25 PM.


#78 RangerMNDN

    Member

  • Pip
  • The Ironclad
  • The Ironclad
  • 19 posts

Posted 19 December 2019 - 04:43 PM

View PostLordNothing, on 19 December 2019 - 12:22 PM, said:


i cant really test it but i used to own at some point the old style gameport ff joystick. assuiming it has the same button layout as i remember.

START_BIND
NAME: Microsoft Sidewinder 3D Force Feedback
VID: 0x045E
PID: 0x001B
BUTTON: InButton=GenericUSBController_Button1, OutButtons=Joystick_Button1
BUTTON: InButton=GenericUSBController_Button2, OutButtons=Joystick_Button2
BUTTON: InButton=GenericUSBController_Button3, OutButtons=Joystick_Button3
BUTTON: InButton=GenericUSBController_Button4, OutButtons=Joystick_Button4
BUTTON: InButton=GenericUSBController_Button5, OutButtons=Joystick_Button5
BUTTON: InButton=GenericUSBController_Button6, OutButtons=Joystick_Button6
BUTTON: InButton=GenericUSBController_Button7, OutButtons=Joystick_Button7
BUTTON: InButton=GenericUSBController_Button8, OutButtons=Joystick_Button8
BUTTON: InButton=GenericUSBController_Hat1, OutButtons=Joystick_Hat_1
BUTTON: InButton=GenericUSBController_Hat2, OutButtons=Joystick_Hat_2
BUTTON: InButton=GenericUSBController_Hat3, OutButtons=Joystick_Hat_3
BUTTON: InButton=GenericUSBController_Hat4, OutButtons=Joystick_Hat_4
BUTTON: InButton=GenericUSBController_Hat5, OutButtons=Joystick_Hat_5
BUTTON: InButton=GenericUSBController_Hat6, OutButtons=Joystick_Hat_6
BUTTON: InButton=GenericUSBController_Hat7, OutButtons=Joystick_Hat_7
BUTTON: InButton=GenericUSBController_Hat8, OutButtons=Joystick_Hat_8
AXIS: InAxis=HOTAS_XAxis, OutAxis=Joystick_Axis1, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_YAxis, OutAxis=Joystick_Axis2, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_ZAxis, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.10, DeadZoneMax=0.10, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis3, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE


let me know if it works and i will add it to the list of known working configs.



i had thiss problem too. after changing a control that was moved or rebound after the patch, my rudder stopped working. i had to go into the joystick tab and up the sensitivity, somehow it got reset to zero. if that fixes it i can add it to the list.


View PostLordNothing, on 19 December 2019 - 12:22 PM, said:


i cant really test it but i used to own at some point the old style gameport ff joystick. assuiming it has the same button layout as i remember.

START_BIND
NAME: Microsoft Sidewinder 3D Force Feedback
VID: 0x045E
PID: 0x001B
BUTTON: InButton=GenericUSBController_Button1, OutButtons=Joystick_Button1
BUTTON: InButton=GenericUSBController_Button2, OutButtons=Joystick_Button2
BUTTON: InButton=GenericUSBController_Button3, OutButtons=Joystick_Button3
BUTTON: InButton=GenericUSBController_Button4, OutButtons=Joystick_Button4
BUTTON: InButton=GenericUSBController_Button5, OutButtons=Joystick_Button5
BUTTON: InButton=GenericUSBController_Button6, OutButtons=Joystick_Button6
BUTTON: InButton=GenericUSBController_Button7, OutButtons=Joystick_Button7
BUTTON: InButton=GenericUSBController_Button8, OutButtons=Joystick_Button8
BUTTON: InButton=GenericUSBController_Hat1, OutButtons=Joystick_Hat_1
BUTTON: InButton=GenericUSBController_Hat2, OutButtons=Joystick_Hat_2
BUTTON: InButton=GenericUSBController_Hat3, OutButtons=Joystick_Hat_3
BUTTON: InButton=GenericUSBController_Hat4, OutButtons=Joystick_Hat_4
BUTTON: InButton=GenericUSBController_Hat5, OutButtons=Joystick_Hat_5
BUTTON: InButton=GenericUSBController_Hat6, OutButtons=Joystick_Hat_6
BUTTON: InButton=GenericUSBController_Hat7, OutButtons=Joystick_Hat_7
BUTTON: InButton=GenericUSBController_Hat8, OutButtons=Joystick_Hat_8
AXIS: InAxis=HOTAS_XAxis, OutAxis=Joystick_Axis1, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_YAxis, OutAxis=Joystick_Axis2, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.02, DeadZoneMax=0.02, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_ZAxis, OutAxis=Throttle_Axis1, Invert=TRUE, Offset=0.5, DeadZoneMin=-0.10, DeadZoneMax=0.10, MapToDeadZone=TRUE
AXIS: InAxis=HOTAS_RZAxis, OutAxis=Joystick_Axis3, Invert=FALSE, Offset=-0.5, DeadZoneMin=-0.08, DeadZoneMax=0.08, MapToDeadZone=TRUE


let me know if it works and i will add it to the list of known working configs.



i had thiss problem too. after changing a control that was moved or rebound after the patch, my rudder stopped working. i had to go into the joystick tab and up the sensitivity, somehow it got reset to zero. if that fixes it i can add it to the list.

I tried your solution and It didn't work any other Ideas.

#79 LordNothing

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • Littlest Helper
  • Littlest Helper
  • 11,181 posts

Posted 19 December 2019 - 05:00 PM

View PostRangerMNDN, on 19 December 2019 - 04:43 PM, said:



I tried your solution and It didn't work any other Ideas.


check the sensitivity settings in the joystick tab in game. game defaults them to zero for some stupid reason.

also check the bindings in the joystick tab. make sure joystick axes 1-3 and throttle axis 1 are bound correctly.

Edited by LordNothing, 19 December 2019 - 05:02 PM.


#80 RangerMNDN

    Member

  • Pip
  • The Ironclad
  • The Ironclad
  • 19 posts

Posted 21 December 2019 - 06:32 AM

I went into saved hotasremapp and deleted joystick axis 3. And changed OutAxis=Joystick_Axis3, Invert=FALSE, Offset=-0.498039, DeadZoneMin=-0.1, DeadZoneMax=0.1, MapToDeadZone=TRUE and it is now working.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users