Jump to content

Li Song Mechlab - 2.0.9

LSML mechlab smurfy

294 replies to this topic

#281 Li Song

    Member

  • PipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 224 posts
  • LocationSweden

Posted 01 August 2017 - 10:06 AM

Status update: https://www.patreon.com/posts/13590063

#282 arcana75

    Member

  • PipPipPipPipPipPipPipPip
  • Shredder
  • Shredder
  • 1,161 posts

Posted 19 October 2017 - 07:54 PM

Hi, is this tool still being maintained? Seems like the tool needs to be updated every time there's a change to the XML files? I'm also using the Steam version, did change the folder to point to the steam folder, but doesn't seem to be working, most likely due to newer xml file versions, given the various patches in Oct 2017.

#283 Li Song

    Member

  • PipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 224 posts
  • LocationSweden

Posted 03 December 2017 - 05:17 AM

@arcama75

I recently moved abroad and started a new job and didn't have internet for 3 months. There were regular status updates on Patreon just like the one right before your post.

That said I'm trying to get a patch out in the coming weeks but a lot of things have changed.

#284 arcana75

    Member

  • PipPipPipPipPipPipPipPip
  • Shredder
  • Shredder
  • 1,161 posts

Posted 04 December 2017 - 05:49 AM

View PostLi Song, on 03 December 2017 - 05:17 AM, said:

@arcama75

I recently moved abroad and started a new job and didn't have internet for 3 months. There were regular status updates on Patreon just like the one right before your post.

That said I'm trying to get a patch out in the coming weeks but a lot of things have changed.

Thanks for the update Li Song!

#285 Li Song

    Member

  • PipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 224 posts
  • LocationSweden

Posted 17 December 2017 - 01:36 PM

Please do consider supporting LSML through Patreon

I rarely play MWO any more and I keep LSML updated mostly because I'd hate to see it die. But it takes away a lot of my free time to do so. If you find LSML useful, please do consider becoming a Patreon to support the continued development of LSML.

Just for curiosity, for this release I had to:
  • Modify 284 files.
  • Change around 8500 lines of code.
  • Spend around 20 days of my free time.
The 2.0.8 update is available from the usual place: https://github.com/E...releases/latest

Edited by Li Song, 17 December 2017 - 01:37 PM.


#286 Steve Marik

    Rookie

  • Knight Errant
  • Knight Errant
  • 1 posts

Posted 28 December 2017 - 01:36 PM

Your program requests that I install Java Runtime Environment 9.0.1 in order for it to run. Could you please supply me with the future date of that Java release so that I can plan on using your program on that date because Java is only on version 8 update 151. Thank you in the future for the ability to use your program.

#287 arcana75

    Member

  • PipPipPipPipPipPipPipPip
  • Shredder
  • Shredder
  • 1,161 posts

Posted 28 December 2017 - 07:38 PM

View PostSteve Marik, on 28 December 2017 - 01:36 PM, said:

Your program requests that I install Java Runtime Environment 9.0.1 in order for it to run. Could you please supply me with the future date of that Java release so that I can plan on using your program on that date because Java is only on version 8 update 151. Thank you in the future for the ability to use your program.

JRE9.0.1 exists. You need to look harder, and avoid confusing the JRE for browser with the JRE for standalone apps. Browser JRE is indeed 8.151, but I was able to download JRE 9.0.1 for standalone Java just fine.

Here maybe this will help: http://download.orac...ows-x64_bin.exe

EDIT: BTW click at your own risk, cuz it's an EXE link and mods if there's a problem with exe links pls delete. The link is to Oracle.com.

Edited by arcana75, 28 December 2017 - 07:39 PM.


#288 BTGbullseye

    Member

  • PipPipPipPipPipPipPipPip
  • The Fearless
  • The Fearless
  • 1,444 posts
  • LocationI'm still pissed about ATMs having a minimum range.

Posted 29 December 2017 - 01:40 AM

That link will not allow a download, mainly because you don't get to click on the "accept terms" button... I also am having trouble finding my way to the 9.0.1 JRE on the Oracle site.

[EDIT] Their site is extremely stupid, and changes the list of available Java downloads if you do a search before using their "menu". Here is a good link to their download location: http://www.oracle.co...oads/index.html Go for the JRE, not the JDK.

Edited by BTGbullseye, 29 December 2017 - 01:44 AM.


#289 arcana75

    Member

  • PipPipPipPipPipPipPipPip
  • Shredder
  • Shredder
  • 1,161 posts

Posted 29 December 2017 - 03:44 AM

Yeah u need to click on their accept button. But I honestly didn't have difficulty finding the EXE.

http://lmgtfy.com/?q=jre+9.0.1

Literally the first hit.

#290 xkilroyx

    Rookie

  • Ace Of Spades
  • Ace Of Spades
  • 2 posts

Posted 02 May 2018 - 02:13 PM

I tried downloading the 9.01 but is now 10.01 and I get same message. I've tried multiple times to do this and not sure what else to try. I have downloaded the JRE win version 64 bit exe for Jre 10.0.1 . I get same error This application requires a java Runtime Environment 9.0.1. =i Any help would be appreciated.

#291 Tier5ForLife

    Member

  • PipPipPipPipPipPip
  • Survivor
  • 481 posts

Posted 02 May 2018 - 03:39 PM

Will not work for Chrome, but then a number of things will not now.

How do I make it work on IE? It seems to be stuck on Chrome.

OK, it does not work on IE so I'm trying the latest Firefox. How do I make it go there? Totally close Chrome?

Edited by LikeUntoBuddha, 02 May 2018 - 03:48 PM.


#292 Li Song

    Member

  • PipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 224 posts
  • LocationSweden

Posted 05 July 2018 - 10:03 AM

View Postxkilroyx, on 02 May 2018 - 02:13 PM, said:

I tried downloading the 9.01 but is now 10.01 and I get same message. I've tried multiple times to do this and not sure what else to try. I have downloaded the JRE win version 64 bit exe for Jre 10.0.1 . I get same error This application requires a java Runtime Environment 9.0.1. =i Any help would be appreciated.


This will be fixed in the next release coming in a few weeks. For now you can install an older Java 9 VM or just launch the .jar file directly from the program folder (instead of the the .exe file. The .exe file is just a wrapper for the .jar).

#293 Li Song

    Member

  • PipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 224 posts
  • LocationSweden

Posted 08 July 2018 - 08:17 AM

Teaser of MWO import/export functionality coming in 2.0.9
https://www.patreon.com/posts/19941178

#294 Li Song

    Member

  • PipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 224 posts
  • LocationSweden

Posted 29 July 2018 - 04:55 AM

The 2.0.9 update is available from the usual place:
https://github.com/E...releases/latest

#295 Li Song

    Member

  • PipPipPipPipPipPip
  • Bad Company
  • Bad Company
  • 224 posts
  • LocationSweden

Posted 29 July 2018 - 05:11 AM







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users