Jump to content

High-End User.cfg File


372 replies to this topic

#321 Reno Blade

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Blade
  • The Blade
  • 3,358 posts
  • LocationGermany

Posted 30 April 2014 - 09:25 AM

From the patchnotes:

Quote

General

The following configuration variables have been exposed for tuning in your user.cfg file. To add these to your user.cfg file navigate to C:\Program Files (x86)\Piranha Games\MechWarrior Online (or your custom installation location) and if it doesn't exist, create a file user.cfg containing these settings as desired. Don't forget to set the value desired.

- gp_option_ShowCockpitGlass=0/1 (off/on)
- r_DepthOfField=0/1 (off/on)
- r_HDRGrainAmount=0.0-1.0 (film grain amount)




I noticed no difference with DoF on or off (with no other options in the config) at very high settings.

Here are before/after screenshots with the 3 new commands on/off (deleted shader folder each time) and the 3rd one with my full user.cfg (including these 3 commands off) from this thread (DX9).
All screenshots with DX11.

Now the question is, which is on and wich is off ^_^
I think the 2nd is with film grain (greenish)
1
Posted Image
2
Posted Image
3
Posted Image

#322 Fatbat

    Member

  • PipPipPip
  • 75 posts
  • LocationCosta del Sol, Spain

Posted 30 April 2014 - 11:18 AM

Can someone please point me to the latest and best high end cfg file for DX11?



Anyone at all?

Edited by Fatbat, 30 April 2014 - 01:39 PM.


#323 Fatbat

    Member

  • PipPipPip
  • 75 posts
  • LocationCosta del Sol, Spain

Posted 30 April 2014 - 01:50 PM

View PostReno Blade, on 30 April 2014 - 09:25 AM, said:

From the patchnotes:


I noticed no difference with DoF on or off (with no other options in the config) at very high settings.

Here are before/after screenshots with the 3 new commands on/off (deleted shader folder each time) and the 3rd one with my full user.cfg (including these 3 commands off) from this thread (DX9).
All screenshots with DX11.

Now the question is, which is on and wich is off :D
I think the 2nd is with film grain (greenish)
1
Posted Image
2
Posted Image
3
Posted Image


How are you using your full config file for DX9 and taking screenshots in DX11? None of the DX9 config files I've used look any good in DX11. Where does one get this DX11 user.cfg file? I'm scouring this and other threads but the files linked in the OP here were last modified in January and I don't know if they are DX9 or DX11. Where's the DX11 cfg file? Why does it all have to be such a mystery? Why can't people label things properly?

Clearly your last screenshot is vastly superior to the others, with no haze, and much better visibility. Anyone running that cfg is going to have a definite advantage over someone who isn't. And I wondered why people were shooting me from the other side of the map when there's no obvious line of sight or visibility.

Where does this cfg come from? Please help, this is driving me mad.

Edited by Fatbat, 30 April 2014 - 01:56 PM.


#324 p4r4g0n

    Member

  • PipPipPipPipPipPipPipPip
  • Knight Errant
  • 1,511 posts
  • LocationMalaysia

Posted 30 April 2014 - 04:52 PM

A user.cfg file is just a txt file. Open up notepad, copy this into it:-

gp_option_ShowCockpitGlass=0/1 (off/on)
r_DepthOfField=0/1 (off/on)
r_HDRGrainAmount=0.0-1.0 (film grain amount)

Save the file as user.cfg in your MechWarrior Online folder. Make sure it is saved as user.cfg and not user.cfg.txt

#325 Reno Blade

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Blade
  • The Blade
  • 3,358 posts
  • LocationGermany

Posted 01 May 2014 - 01:30 AM

View PostFatbat, on 30 April 2014 - 01:50 PM, said:


How are you using your full config file for DX9 and taking screenshots in DX11? None of the DX9 config files I've used look any good in DX11. Where does one get this DX11 user.cfg file? I'm scouring this and other threads but the files linked in the OP here were last modified in January and I don't know if they are DX9 or DX11. Where's the DX11 cfg file? Why does it all have to be such a mystery? Why can't people label things properly?

Clearly your last screenshot is vastly superior to the others, with no haze, and much better visibility. Anyone running that cfg is going to have a definite advantage over someone who isn't. And I wondered why people were shooting me from the other side of the map when there's no obvious line of sight or visibility.

Where does this cfg come from? Please help, this is driving me mad.


Hi there Fatbat,

I still use the config from Padas package (very high) with a few changes.
first, make sure you don't have the line q_ShaderPostProcess = 4 in your config. This made a mess out of DX11 when released.
Not sure if they fixed it, but we had to remove it at that time.
see here:

View PostReno Blade, on 04 March 2014 - 03:04 PM, said:

Yes. Find this line:
q_ShaderPostProcess = 4
and either remove it, or put a ; infront (comment out to disable it).
This one makes DX11 eat itself alive.
you need to use the slider for PostProcessing ingame for any change of that instead.


second, Padas last config (ultra high) was a slightly modified one from the package with a few higher/lower values for texture size and such.
see here:

View PostColonel Pada Vinson, on 05 March 2014 - 09:51 PM, said:

and another updated user.cfg you can try. This is for very high spec and will be (7) when added to the package. adds some bonus ssdo & hdr / bloom for nicer lasers too.

this config should fix the green smoke problem.

culprit looks to be r_FogShadows = 1, disable that line in your cfg and see if that fixes the green fog for you. this cfg below fixed the green fog for me.

Spoiler



and third,
to be complete, here is my user config, which is nearly identical:
Spoiler


#326 Iqfish

    Member

  • PipPipPipPipPipPipPipPipPip
  • 3,483 posts
  • Google+: Link
  • LocationGermany, CGN

Posted 01 May 2014 - 04:04 AM

None of the user.cfgs inside Padas .rar file from the OP work for me.

They cause my MechLab to turn all black and the game to behave really really weird when dropping into testin grounds (lockups, HUD gets messed up)

When I use Renos user.cfg it works perfectly and looks awesome.

I really want to write a guide for this and link it to some inexperienced people but as long as i don't know whats wrong with the original user.cfgs I can't do that :)

Edited by Iqfish, 01 May 2014 - 04:05 AM.


#327 Reno Blade

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Blade
  • The Blade
  • 3,358 posts
  • LocationGermany

Posted 01 May 2014 - 05:14 AM

The black mechlab and messy graphics come from that line q_ShaderPostProcess = 4
I think it's in all the others of the pack also with varying values ofc.

And best to delete the shader folder after changing the config to be sure to have everything refreshed.
First time on each map will be laggy because the textures are beeing cached, but you can go into testing grounds to do that too :rolleyes:

#328 Todd Lightbringer

    Member

  • PipPipPipPipPipPip
  • The Universe
  • The Universe
  • 450 posts

Posted 02 May 2014 - 05:03 PM

I'm trying to turn glass off and such, but for some reason it just doesn't want to cooperate!

Here is my user.cfg file.

Spoiler

Edited by Todd Lightbringer, 02 May 2014 - 05:05 PM.


#329 Wintersdark

    Member

  • PipPipPipPipPipPipPipPipPipPipPip
  • 13,375 posts
  • Google+: Link
  • Twitter: Link
  • LocationCalgary, AB

Posted 02 May 2014 - 05:20 PM

Get rid of the leading "- " on each of those three lines.

It should be:
gp_option_ShowCockpitGlass=0
r_DepthOfField=1
r_HDRGrainAmount=0.0

The dashes where just because the entries where in list form.

Also, r_DepthOfField=0 unless you really like unnecessary blur.

Edited by Wintersdark, 02 May 2014 - 05:22 PM.


#330 Todd Lightbringer

    Member

  • PipPipPipPipPipPip
  • The Universe
  • The Universe
  • 450 posts

Posted 02 May 2014 - 05:38 PM

View PostWintersdark, on 02 May 2014 - 05:20 PM, said:

Get rid of the leading "- " on each of those three lines.

It should be:
gp_option_ShowCockpitGlass=0
r_DepthOfField=1
r_HDRGrainAmount=0.0

The dashes where just because the entries where in list form.

Also, r_DepthOfField=0 unless you really like unnecessary blur.


Think that did her, thank you kindly!

#331 Reno Blade

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Blade
  • The Blade
  • 3,358 posts
  • LocationGermany

Posted 05 May 2014 - 09:22 AM

With that config, did anyone else get black vision when using heat/night vision mode on colony?

#332 BladeXXL

    Member

  • PipPipPipPipPipPipPipPip
  • Ace Of Spades
  • Ace Of Spades
  • 1,098 posts
  • LocationGermany

Posted 06 May 2014 - 07:26 AM

some cvars used here screw up the color-gama and/or texturing for some GPUs.
so recomend to wait until PGI fully unlocks the user.cfg ... so we can rework this outdated configs.

#333 Hammerhai

    Member

  • PipPipPipPipPipPipPip
  • The Raider
  • The Raider
  • 992 posts

Posted 06 May 2014 - 08:45 AM

So sad that Colonel Vinson departed. I simply do not have the know how to trouble shoot sophisticated stuff like that.

Btw, the Nvidia GTX 680 seems to be unaffected by this. However I have sys spec shader set to 1 rather than 4. Try that.

This is the line I am referring to:

sys_spec_PostProcessing = 1. Of course I do not actually know what it does. If I was an engineer I would be out of a job ...

Edited by Hammerhai, 06 May 2014 - 08:50 AM.


#334 Reno Blade

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Blade
  • The Blade
  • 3,358 posts
  • LocationGermany

Posted 06 May 2014 - 09:06 AM

The sys_spec_xyz lines are refering to the sliders ingame. Setting them up to 1-4 (or is it 0-3?) would be the same as the sliders.

#335 BladeXXL

    Member

  • PipPipPipPipPipPipPipPip
  • Ace Of Spades
  • Ace Of Spades
  • 1,098 posts
  • LocationGermany

Posted 07 May 2014 - 06:38 AM

Exactly what Reno said!
...and btw.:
adding sys_spec_PostProcessing = 1 won't cause anything
MWO will overwrite it with the current value of the options slider!

#336 Vodage

    Member

  • PipPip
  • Survivor
  • 43 posts

Posted 06 June 2014 - 02:11 PM

I see a lot of CFG's posted with really pretty graphics. I'm looking for something more like this

Edit: video isn't embedding properly >< http://youtu.be/DreDIhnK-co


^Most pro QL players run settings like these. Granted, Quake is a different style of game, where neon green enemies have become tournament standard. So maybe PGI won't let me remove all textures from all surfaces through the CFG-- but can I at least get blob shadows? Howabout less of this blockbuster-esque overexaggeration of every particle effect? Foliage elimination would be nice, too. If I can shoot through it, I should be able to see through it ;)

Has anyone put together a CFG for max visibility? ...the tournament players perhaps? ;)

Edited by Vodage, 06 June 2014 - 02:16 PM.


#337 Reno Blade

    Member

  • PipPipPipPipPipPipPipPipPip
  • The Blade
  • The Blade
  • 3,358 posts
  • LocationGermany

Posted 06 June 2014 - 02:17 PM

First, use [ media ] tags, or just use the plain youtube link, as it gets embedded automatically.
and second, this is not allowed and a lot of config parameters are either locked at different min/max values, or can't be changed anymore, because some settings were clearly too close to this and that is considered cheating.

#338 Vodage

    Member

  • PipPip
  • Survivor
  • 43 posts

Posted 06 June 2014 - 02:32 PM

Yes, so I'm saying. Has anyone figured out the farthest we can push it without cheating? I just want to see across the map as good as the next guy. If some values are locked at a range of min/max, it would be helpful to post that min/maxed CFG, so everyone is on a more level playing field visually, at least as far as combat goes. I'm not worried whose rig can run the game with full AA and whose can't-- more worried about all the poor saps who're still squinting through cockpit glass.

#339 Legend_

    Member

  • PipPipPipPipPipPip
  • 252 posts
  • LocationSweden

Posted 14 June 2014 - 02:40 AM

Does anyone have or know of a list of cvars that can be used in the user.cfg without needing to add or modify files, especially commands that will clear up the game and make it look crisper and generally better?

#340 WheezerX

    Member

  • PipPip
  • The Boombox
  • The Boombox
  • 47 posts
  • LocationWest Virginia, USA

Posted 11 July 2014 - 12:05 AM

Link is busted for CFG download





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users